RDP stop working on Win 2003

Posted on 2011-04-20
Last Modified: 2012-06-21

After the SP2 update on my windows 2003 server I cannot connect anymore with RDP on it (from lan and wan)

I don't have the Termnial service installed I only use RDP for administrator management.

So this is what I check.

- Verify my windows firewall.
- Verify that the RDP was correctly activated on my server.
- The listening port in my registry is 3389.
- netstat -an nothing is listening on 3389
- tasklist 5620 nothing much...
- telnet to 3389 also told me that the port isn't listening.

I also try to export the winstation registry key from a working server to this one..

I'm out of solution.. can you help me out with this ?

Thank you

Question by:tblinc
    LVL 10

    Expert Comment

    Try looking at this:

    From it may also be worth re-installing the latest version of Remote Desktop Client on both server and PC.

    Author Comment

    Thank you Martin for your quick answer. Unfortunately, I also already apply those patch.

    I installed  RDP6.0 on my server but not on my client.. but I think it's useless since I can't even telnet to my server using port 3389.

    I also apply this : An update to turn off default SNP features is available for Windows Server 2003-based and Small Business Server 2003-based computers

    Thanks for your support.
    LVL 26

    Expert Comment

    Look in the event logs for clues.  Anything in the system event log?  

    If you see TermDD  eventID 50, check this out:  It refers to Windows 2000, but it also affects Server 2003.
    LVL 38

    Accepted Solution

    This is actually a common problem:

    Assuming this worked before:
    You may have updated to SP2. There is a little quirk with SP2 that requires two reboots prior to RDP and TS working.

    Most likely cause:
    Here are a couple more issues with SP2. One of the, TS fails to listen on the default port.

    Author Comment

    I rebooted more than two times.

    Author Comment

    I'll try to reinstall SP2.
    LVL 38

    Expert Comment

    It wasn't a bad download of the service pack. It's what the Service pack did to the listening port of terminal services. To allow more connections, SP2 changed the listening port to a dynamic listening port. You can hard code the listening port back to 3389.

    Author Closing Comment

    The reinstallation of SP2 solved my trouble. Thanks all.

    Featured Post

    Enabling OSINT in Activity Based Intelligence

    Activity based intelligence (ABI) requires access to all available sources of data. Recorded Future allows analysts to observe structured data on the open, deep, and dark web.

    Join & Write a Comment

    Setting up a Microsoft WSUS update system is free relatively speaking if you have hard disk space and processor capacity.   However, WSUS can be a blessing and a curse. For example, there is nothing worse than approving updates and they just have…
    Remote Desktop Shadowing often has a lot of benefits. When helping end users determine problems, it is much easier to see what is going on, what is being slecected and what is being clicked on. While the industry has many products to help with this,…
    How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…
    This video is in connection to the article "The case of a missing mobile phone (". It will help one to understand clearly the steps to track a lost android phone.

    754 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    18 Experts available now in Live!

    Get 1:1 Help Now