We help IT Professionals succeed at work.

Outlook 2010 Automatic Replies gets "Server unavailable"

Medium Priority
4,122 Views
Last Modified: 2012-05-11
I've seen this asked in another thread.  But I'm very confused.

The solution was this:

http://technet.microsoft.com/en-us/library/bb201695(EXCHG.80).aspx

The commands in that link reference external addresses.  This is happening internal to me.  Does that still matter?

Outlook Anywhere has always worked here, so I'm guessing I have 'some" autodiscover stuff configured correctly.

Help!
James


Comment
Watch Question

Author

Commented:
I next found this webpage:

http://www.slipstick.com/exs/cmdlet/oof_failure.asp

From it, I ran Get-webservicesvirtualdirectory | fl identity,internalurl,externalurl in the exchange console and it returned that I had the same url for internal and external which was:

https://mail.myserver.com/ews/exchange.asmx

I figured the internal will not resolve to that behind the firewall, maybe that was the issue, so I ran the reconfig command with the following changes:

Set-WebServicesVirtualDirectory -Identity "MyServer\EWS (Default Web Site)" -InternalURL https://myserver.mydomain.local/EWS/Exchange.asmx -ExternalURL https://mail.myserver.com/EWS/Exchange.asmx -BasicAuthentication:$true

It took, closed Outlook, opened it back up, and still not working.  Ug.

Author

Commented:
Next Update, I found a computer in my network where it works.  So I have to imagine it's something on the client end?

Author

Commented:
I'm starting to see a trend that on any PC that I manually added someone's exchange account into outlook 2010 (because using the name/email address and letting outlook try to pull the server settings doesn't work) has this issue.  I don't know if that helps any exchange gurus out there.
Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION
I've written a couple of article on the configuration for this
Take a look at this article, it should get things working

https://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/A_3704-Troubleshooting-Outlook-Certificate-Errors.html

Author

Commented:
The next day I came in and after putting in an internal A record for the same dns name of the external IP, it started working fine.

If I do a automatic adding of an exchange account in Outlook I still get certificate errors.

But now if I do it manually, I do not get certificate errors, yet the web service stuff (Auto Replies) works, so it may not be set up perfect, but good enough for me.  Thanks for reading.
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.