how to configure RWA in SBS 2011 with SSC?

I am trying to get RWA working on a SBS 2011 using a self-signed certificate.  I have exported the certificate from the server and imported on the client machine.  Prior to doing this i was getting an error yelling about the  certificate not being trusted--blah blah blah.  I have gotten past that error and now I get

"your computer cant connect to the remote computer because the remote desktop gateway server address requested and the certificate sbject name do not match."

I created a new cert with a friendly name matching the website i am trying to connect to and i.  I am stuck now.  any ideas?  what am i missing?  i have noticed that when establishing the connection the publisher shows 'sites' instead of the fqdn--i think this might be my problem.

LVL 2
phrea84Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Cliff GaliherCommented:
Please use the pre-packaged installer when installing a self-generated certificate. Otherwise you are only trusting the cert itself and not the cert root, which causes all manners of issues.

Article below is for SBS 2008, but this hasn't changed in 2011:

http://blogs.technet.com/b/sbs/archive/2008/09/30/how-do-i-distribute-the-sbs-2008-self-signed-ssl-certificate-to-my-users.aspx

-Cliff
phrea84Author Commented:
ok--i used the self signing certificate installer in the public/downloads.  this has gotten me past the error, but now after entering my password it is stuck on "initiating remote connection".  it sits there for about a minute, then times out.  i only have port 443 open--thats all i need for RWA, right?

Any ideas?
phrea84Author Commented:
p.s. sorry for the delay--i never got the email you replied to this and i happened to be checking the status and noticed 1 reply.
Virus Depot: Cyber Crime Becomes Big Business

The rising threat of malware-as-a-service is not one to be overlooked. Malware-as-a-service is growing and easily purchased from a full-service cyber-criminal store in a “Virus Depot” fashion. View our webinar recording to learn how to best defend against these attacks!

Cliff GaliherCommented:
You only need port 443, but some firewalls nay not route traffic as expected. That would be my first guess.
phrea84Author Commented:
OWA is working fine via 443 as is pulling up the website, so it appears the firewall is routing traffic corretly.  How would I troubleshoot RDP not connecting fully?
Cliff GaliherCommented:
OWA is purely web traffic. The remote desktop feature is RDP traffic being run over a secure tunnel on 443. Not all traffic is created equal, so don't assume that just because a website loads that remote desktop connectoins will work.

You should be able to access and test the RWA components even within the network. Connect to the RWA website from one machine, then attempt to make a remote desktop connection to another machine. If this works then you know you have firewall issues.

-Cliff
phrea84Author Commented:
can rdp via software internally, but cannot rdp via remote website internally.  firewall on server is disabled.

thoughts?
phrea84Author Commented:
ok--i got this fixed.  i had some errors in my event logs that were very similiar to http://www.experts-exchange.com/Microsoft/Server_Applications/Q_24941958.html.  these errors started after i ran the 'set up my domain' wizard to create my ssl.  during the wizard, it failed on exchange and crashed it.  luckily, a reboot fixed it and the server seemed fine, but i still had these errors in the logs.

anyways, i wasnt able to resolve the exchange error.  luckily, i had a newly rebuilt sbs 2011 box.  i copied applicationhost.config file from the known good machine to the one i couldnt remote into.  once i did this, i restarted IIS, and BAM--i connected instantly.

Thanks for the help.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
phrea84Author Commented:
solved myself
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VPN

From novice to tech pro — start learning today.