We help IT Professionals succeed at work.

Check out our new AWS podcast with Certified Expert, Phil Phillips! Listen to "How to Execute a Seamless AWS Migration" on EE or on your favorite podcast platform. Listen Now

x

I/O error 0x8007045d copying large folder between drives

Medium Priority
3,864 Views
Last Modified: 2012-05-11
I have a new 64 bit server running MS 2008 Server R2 with 8 Gb RAM, 120 Gb SATA SSD drive for the OS and a 500 Gb data dirve (3 SAS drives in a RAID 5).  The LSI MegaRAID controller manages the drives.
My problem is when I copy a large folder (22 Gb) I recieve an error 0x8007045d: The request could not be performed because of an I/O device error.  I copied the folder from an external USB drive with no problem but when transferring it between drives within the computer is when I recieve the errors.  Copying from the SSD to the RAID it errored 111 times, when going the other direction it errored 41 times - different files, different file types and sometimes multiple times on a single file.
Don't want to put the server into production until I resolve this issue
Comment
Watch Question

I think the problem might be with the SSD drive.  I am not true believer in using an SSD for the operating system I have encountered some problems recently with Solid State Drives....they use Solid State Memory like a USB flash drive and not nearly as reliable as a standard HDD.  I personally would not run a server OS on an SSD drive.  In  your above situation I would buy two more SAS drives and setup the OS on the two drives using Raid1 (Mirror) this will create OS redundancy in the case one of the drive fails.

My gut feeling is the I/O errors you are receiving are coming from the SSD drive.  Have you tried to run the CHKDSK /f command on the SSD drive?

Author

Commented:
Yes, chkdsk detected no problems.
Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION
Ok. So have you also run CHKDSK /f on the SAS Raid drive too?

Have you tested your data transfer between the RAID volume and another network disk or flash drive? Do the errors only occur when copying to or from the SAS?

Author

Commented:
No problem transferring to flash drive.  Can't test to network drive since it isn't setup on a network as of now.  I took the advice from Patmac951 to replace the SSD with a regular HD in a mirror.  Unfortunatly it is still experiencing the same problems.

Commented:
If you have replaced the drives and are still getting the error you could try replacing the cables to the drives. This kind of error indicates that Windows is unable to communicate with the hard drive for some reason. It’s a generic error message but could indicate a hardware fault you should check – hard drives, cables, RAID controller & firmware.

From TechNet
http://technet.microsoft.com/en-us/library/cc978853.aspx

Error Message:
The request could not be performed because of an I/O device error.

User Action:
Check the cabling to your peripheral devices and retry the operation. If you still get this message, run hardware diagnostics. If the diagnostics do not detect a problem, contact the supplier of the running application.

Author

Commented:
I have another controller coming, will see what happens when I get it installed.
Taylor,

Are you sure you the disk controller drivers are the most current manufacturer drivers?  Secondly do you know what the Stripe size is for the RAID arrays?
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION

Commented:
Hey, thats great - glad you got it fixed ;)
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.