We help IT Professionals succeed at work.

Solaris 10 /etc/lp/filter.table corruption following lpsched hang

Craig Sharp
Craig Sharp asked
on
2,769 Views
Last Modified: 2012-05-11
I ran into an issue today where lpsched hung due to a DNS issue with printer names.  When I corrected the DNS issue, restarted the scheduler and tried to print to a local queue (remote printer), I received the following error:

dist431ptr: failed to commit job (32125-0): No filter available to convert job

The root cause was that the /etc/lp/filter.table file had become corrupt.  I copied the file from a sister server, restarted lpsched and the problem was resolved.

This is the second time this issue has occurred.  The first time was not due to DNS issues, but another issue.  The end result of the issue was that lpsched hung.  When the filter.table file was replaced, the issue was resolved.

I am looking for suggestions as to what might be the cause.

5.10 Generic_138888-03 sun4u sparc SUNW,Sun-Fire-V890.

Thanks,

Craig
Comment
Watch Question

Top Expert 2011
Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION
Craig SharpLead Enginneer - Unix Server Team

Author

Commented:
Nothing was in the syslog.  The only thing we had to go on was that the printers were throwing the filter error shown above and we could not communicate.  The DNS was easy as these were all remote printers.  The filter.table issue was more elusive.
Top Expert 2011

Commented:
As the quote from the URL:
Solaris Print Manager automatically adds these filters to a print server.

Does this give you some hints like "Solaris Print Manager" doing something automatically and it could mess up your filter table..... You  might want to check the print manager to see if you can disable automatically update or some sort of...
Craig SharpLead Enginneer - Unix Server Team

Author

Commented:
I see where you are going with this, but this is a system that remains static for months. We have other systems with identical print settle that do not exhibit this issue. This leads me to believe that there is something else happening. I will have a look at the print manager though and see if that may be doing something funny that was triggered by the dns issue. Thanks for you replies.

Craig
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.