• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 541
  • Last Modified:

Sharepoint search not working

Hello Experts,

I am unable to search in SharePoint. all search queries return to

No results matching your search were found.
Check your spelling. Are the words in your query spelled correctly?
Try using synonyms. Maybe what you're looking for uses slightly different words.
Make your search more general. Try more general terms in place of specific ones.
Try your search in a different scope. Different scopes can have different results.
 
 
This is a stand alone config. I have fixed this issue before with a stsadm command but cant think of it right now ( shud have documented)

Would be great if someone can help me out!
R
 
0
rohitsurya
Asked:
rohitsurya
4 Solutions
 
c0sCommented:
if you go in the administration page and check the status of the services, the search or indexing service might be stopped
0
 
rohitsuryaAuthor Commented:
Thank for the quick comment. Can you be more specific where i should look?

Thanks!
0
 
rohitsuryaAuthor Commented:
Services on Server Checked. Search service is running. Also restarted search service from services.
0
Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

 
sharkbot221984Commented:
Are there any errors in the Application Event Log?
0
 
c0sCommented:
sharepoint central administration -> application management -> manage services on this server

and check for SharePoint Server Search
0
 
rohitsuryaAuthor Commented:

Its working now after i did these three things,

1) restarted the server
2) restarted the search service
3) did a full crawl under search adminitration

but i am stil not sure why my server updates option got disabled? and the event viewer gave this error

Could not access the Search service configuration database.

the default account is set to my AD and i recently changed password. So updated that also.

But its fixed now!!
0
 
c0sCommented:
it might help to make the password for that account to never expire and prevent remote logon in case needed
0
 
kukdaiCommented:
update your default access content in the search too with that account and new password...Make sure for services you use service accounts with password never expires...
0
 
rohitsuryaAuthor Commented:
Partially guided the solution.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now