Can't open php files served from ubuntu/apache

I've got ubuntu 8 that I just installed apache2 and php5. I can load html files fine from the server but whenever I try to load a php file it says "what should firefox do with this file?" and wants to save it as a file. I have looked everywhere and tried everything. How can I get php files to open correctly?
Who is Participating?
underskyConnect With a Mentor Commented:
also check /etc/apache2/sites-available/

your directory settings must be like this:

      <Directory />
            Options FollowSymLinks
            AllowOverride All
            Order allow,deny
            Allow from all
Are you trying to open the file directly, or going to http://servername/filenam.php?
is PHP actually up and running on the server?
try sudo a2enmod php5

also add index.php file, and try simple php script after
steiner470Author Commented:
Well done, that fixed it
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.