Installing Matplotlib

I have the Phyton installation in Eclipse  referenced in the following line.  My Current environment is Windows 7 64bit.

C:\Python27\python.exe 2.7.1 (r271:86832, Nov 27 2010, 17:19:03) [MSC v.1500 64 bit (AMD64)]

I neet to install matplotlib but when I execute the installation program (matplotlib-1.0.0 win.amd 64py2.6.exe) the following message is displayed

"Phython version 2.6 required which was not found in the registry.

Does anyone knows how to resolve the above mentioned problem?
cotoslAsked:
Who is Participating?
 
mish33Commented:
Not for binary extensions like the one you're trying. 2.7 supports Python code written for 2.6
0
 
gheistCommented:
Python version 2.6 is different from 2.7 you have
Install v2.6 aside and it will work.
0
 
cotoslAuthor Commented:

Thank for your response.   I understand that 2.7 is the last of the 2.x releases and that 2.7 is paving the road for 3.1 but I would expect that  2.7 would support  2.6 applications.  
0
 
gheistCommented:
http://www.activestate.com/activepython/downloads

you can have 2.6 and 2.7 and 2.4 and 3.2 all on same system.

0
 
LeeTutorretiredCommented:
This question has been classified as abandoned and is closed as part of the Cleanup Program. See the recommendation for more details.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.