Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 425
  • Last Modified:

Mapping a site collection through an extended web application

I have a SharePoint 2010 implementation with two web applications.  One is the "root" web application http://<URL>:80/ and the second is the Central administration web app.  The root web application has two site collections in it under ../sites/<site collection>

I have extended the "root" web to a new site for the extranet zone.  I can get to the root site through the newly created URL but not to the site collections underneath "../sites/".   Any thoughts on what I have missed?

I can provide more detail as I realize that this is somewhat lacking on the finer points.

Thanks
0
jima92119
Asked:
jima92119
  • 4
  • 2
2 Solutions
 
Minesh ShahSharePoint & all about itCommented:
i m not very sure, but guess you need to enter site colloections into the Alternate Access Mapping
0
 
Justin SmithSr. System EngineerCommented:
Did you manually add the new host header to IIS?
0
 
jima92119Author Commented:
Ach1lles,

I did not supply a new host header as I extended the web application into a new web site.  The process of exteding the web application created an alternate access mapping but I did not supply a host header.  Some additional detail is that I setup the extension for the extranet zone and configured it for SSL on port 443.

I am going to inculude a screen shot of the settings for when I did the extension in the off chance it may spark a thought.  Please let me know what other information I can provide that might help.  I will try creating new aam entries as MineSharePoint has suggested.  If that resolves the issue then I will let you know.

   A screenshot of settings from the web app extension.
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
Justin SmithSr. System EngineerCommented:
THis is the only site in IIS on port 443, correct?
0
 
jima92119Author Commented:
Correct.  There are no other sites on 443.
0
 
jima92119Author Commented:
The answer turned out to be a combination of alternate access mapping entries AND how the request was being made via the fully qualfied domain name within our intranet.
Some requests to the URL were being passed on with the fqdn and there was no AAM entry for the FQDN as an internal URL and the public URL that was being accessed.
By adding the AAM between the two the problem was resolved.
0
 
jima92119Author Commented:
My final comments added additional information and the final resolution to the problem.  While it is generally not necessary to add aam entires for the web application beyond what SharePoint creates when the application is extended, in this case there were two ways the web application was being addressed and the AAM entries had to account for both.
0

Featured Post

Get your Conversational Ransomware Defense e‑book

This e-book gives you an insight into the ransomware threat and reviews the fundamentals of top-notch ransomware preparedness and recovery. To help you protect yourself and your organization. The initial infection may be inevitable, so the best protection is to be fully prepared.

  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now