?
Solved

WSS 3.0 Search Service won't start using Central Admin

Posted on 2011-04-20
4
Medium Priority
?
1,010 Views
Last Modified: 2012-08-14
Hi everyone,

I am using WSS 3.0 with SQL 2005 in a farm configuration. I have tried many times to start the "Windows SharePoint Services Search" in Central Admin but I receive a Server Error in '/' Application.

Any ideas what this might be from? I have tried everything and running out of ideas. I have one AD accounts that I checked have access to the SQL server, and is also a FARM administrator. I have also tried a non-FARM admin account and I am getting the same error. The Application event logs have the following error:

Evetn ID 1003
Information 04/20/2011 4:57:13 PM Windows SharePoint Search Services 3 Search
Description: The search service started

Event ID 10035
Warning 04/20/2011 4:57:13 PM Windows SharePoint Search Services 3 Search
Description: Could not import the registry hive into the registry because it does not exist in the configuration database.

Event ID 2426
Error 04/20/2011 4:57:16 PM Windows SharePoint Search Services 3 Search
Description: Advise Status Change Failed. The system is probably low on resources. Free up resources and restart the service.
Context: Application 'Search' Catalog "index file on search server Search'
Details: 0x80041812

Event ID 10029
Error 04/20/2011 4:57:16 PM Windows SharePoint Search Services 3 Search
backing up the registry hive to the configuration database. Context: Application 'Search index file on search server'
Details: Access is denied (0x80070005)


0
Comment
Question by:RetiredScriptingGuy
  • 2
4 Comments
 
LVL 6

Expert Comment

by:ezskol
ID: 35437741
Was there any update recently applied to the WSS server?

Is there enough disk space on the server?

http://claytonj.wordpress.com/2008/11/18/wss-30-search-database/  <--- has the same event id errors as you are currently experiencing.

http://msdn.microsoft.com/en-us/library/aa952804%28v=bts.20%29.aspx



0
 
LVL 38

Expert Comment

by:Justin Smith
ID: 35440096
So are you low on system resources?
0
 
LVL 1

Accepted Solution

by:
RetiredScriptingGuy earned 0 total points
ID: 35479613
We are still not sure why the system resources are low. We are still troubleshooting by changing the Application Pool Size "Maximum Virtual Memory (in Megabytes)" to reduce the number of errors.

The Search is working now, what I did was log onto the Server using the Service Account and then verified that with that account I could:
1. read/open the database
2. read/open the registry
3. read/open the 12 hive
4.read/open the index file location
5. make sure the account was listed as a Farm, Local Admin, and SQL dbo

After verifying those were correct, I configured SP Search just using STSADM Commands.
1. "STSADM -o SPSEARCH STOP"
2. Then answer Yes to delete the index files
3. "STSADM -o SPSEARCH START"
4. "STSADM -o SPSEARCH -action List" (to print out the SQL database server, database name, and verify all the content dbs and index locations are listed
5. "STSADM -o SPSEARCH -action fullcrawlstart -farmserviceaccount <Domain\UserName> -farmservicepassword "<insert password>" -databaseserver spssvr114 -databasename WSS_Search4_spssvr094
0
 
LVL 1

Author Closing Comment

by:RetiredScriptingGuy
ID: 35503415
The trick was if the GUI is producing errors, make sure you try to use the STSADM Commands.
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Pimping Sharepoint 2007 without Server-Side Code Part 1 One of my biggest frustrations with Sharepoint 2007 in the corporate world is that while good-intentioned managers lock down the more interesting capabilities of Sharepoint programming in…
The vision: A MegaMenu for a SharePoint portal home page The mission: Make it easy to maintain. Allow rich content and sub headers as well as standard links. Factor in frequent changes without involving developers or a lengthy Dev/Test/Prod rel…
Exchange organizations may use the Journaling Agent of the Transport Service to archive messages going through Exchange. However, if the Transport Service is integrated with some email content management application (such as an anti-spam), the admin…
Loops Section Overview
Suggested Courses

809 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question