We help IT Professionals succeed at work.

flashing SWC component in Flash IDE

Medium Priority
498 Views
Last Modified: 2012-05-11
I've made a compiled custom component and put it in the components folder on C:

When I drag it to the stage it looks fine just the outline shows coz I done have a preview yet.

But when I click on it it starts flashing (in the IDE).  Any idea why?

If I run the app the component works fine.

Comment
Watch Question

Do you have any click event on that.
Though I am not sure if compiled clips can track the click on stage.
Also check if the the Enable Simple Buttons option under control menu is activated.

The flickering may happen if the click is enabled and the component tries to do some action which require runtime compilation and hence failing causing to show the flickering.

Warm Regards
Deepanjan Das

Author

Commented:
Actually I dont have to click on it. Just clicking anywhere in the stage (in the IDE) starts it flashing.

I'm only do some very trivial code stuff in the class so it must be the way I'm implementing the component.

Maybe it's coz I dont have a live preview. Will try that now.
Not for live preview not being added I feel.
Kindly check the export flash player version for the movie.

Warm Regards
Deepanjan Das

Author

Commented:
ok, for all those who cant wait to find out :)
It was fixed by adding a LivePreview swf.

Author

Commented:
hi mate, thanks for the help :)
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.