• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 364
  • Last Modified:

LDAP USER in web config file

Hi, a pice of work has hit my desk for sharepoint. but looking in to the web config file of teh SITE
I see a username and password in clear text.
developer tells me it needs these to question AD.

but surley there must be a way with out putting the username and password in?  attatched is the relevant code  I have removed the values for username and password.

but  it works when you eneter a username and password and doesnt work when you dont :-)

what options do i have?

thanks

IIS6 sharepoint 2007   bespoke apps


<applicationSettings>
        <green.blue.ABC.UI.CaseFolderActions.Properties.Settings>
            <setting name="PublicContactLog" serializeAs="String">
                <value>test_Contact_Log</value>
            </setting>
            <setting name="ContactLog" serializeAs="String">
                <value>WTFH_Contact_Log</value>
            </setting>
        </green.blue.ABC.UI.FolderActions.Properties.Settings>
        
        <green.blue.ABC.UI.SPUtilities.Properties.Settings>
             <setting name="ActionsADAccessGroupName" serializeAs="String">
                <value>blueABC\ABC_Actions</value>
            </setting>
            <setting name="LDAPConnectionString" serializeAs="String">
                <value>LDAP://at-advm-01.domain.blueABC/DC=DOMAIN,DC=blueABC</value>
            </setting>
            <setting name="LDAPUserFilter" serializeAs="String">
                <value>(&amp;(objectCategory=person)(objectClass=user)(memberOf=CN={0},DC=domain,DC=blueABC))</value>
            </setting>
            <setting name="LDAPConnectionUsername" serializeAs="String">
                <value />
            </setting>
            <setting name="LDAPConnectionPassword" serializeAs="String">
                <value />
            </setting>
            <setting name="NamePrefix" serializeAs="String">
                <value>SG_GG_TEST</value>
            </setting>
        </green.blue.ABC.UI.SPUtilities.Properties.Settings>
    </applicationSettings>

Open in new window

0
mhamer
Asked:
mhamer
1 Solution
 
GeorgeGerguesCommented:
I am afraid that has nothing to do with SharePoint in particular .

This is custom code and the developer creating this , requires this type of configuration.

this can be done in so many different ways. ,
the simplest would to put the user name and password (at least with static key key encryption)
another way would be to save the information in a admin type list items (with or without encryption)



Best of luck.
0
 
mhamerAuthor Commented:
I tried encryption, but failed.  Works on other places we have to use passwords but here no joy, back to developer.
0

Featured Post

Receive 1:1 tech help

Solve your biggest tech problems alongside global tech experts with 1:1 help.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now