• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 900
  • Last Modified:

Exchange 2007 Out of office

Hello,

we have a clinet who can access out of office on OWA but not on outlook (server is not available)

I have followed http://support.microsoft.com/kb/940726/ to repoint the virtual directories to the correct urls but it still wont work.

output from test email autoconfig is as follows:

autodiscover FAILED (0x80004005) http status codes of 404 and 403

please help!

0
snagsy1980
Asked:
snagsy1980
  • 10
  • 9
  • 6
  • +1
1 Solution
 
Ahmed786Commented:
Try below shell command

get-webservicesvirtualdirectory | Set-WebServicesVirtualDirectory -WindowsAuthentication:$true

Please reply the output
0
 
snagsy1980Author Commented:
The command completed successfully but no settings of"servername\ews (default web site) have been modified
0
 
Ahmed786Commented:
Try testexchangeconnectivity.com

And then use the outlook connectivity test and post back the results of both
0
Veeam Disaster Recovery in Microsoft Azure

Veeam PN for Microsoft Azure is a FREE solution designed to simplify and automate the setup of a DR site in Microsoft Azure using lightweight software-defined networking. It reduces the complexity of VPN deployments and is designed for businesses of ALL sizes.

 
Ahmed786Commented:
After performing my first command, have u restarted ur exchange services ?

IF not then please restart all the services and try your issue might be resolved.
0
 
Ahmed786Commented:
sorry to mention that please RESTART IIS service as well
0
 
snagsy1980Author Commented:
i cant perform the online test as it the session times out before i complete the details!

but the auto config output is attached
Autoconfig-output.jpg
0
 
praveenkumare_spCommented:
Check the authentication on Autodiscover Virtual Directory > you should have Basic and Integrated

if u have any thing else remove and make sure u have only  Basic and Integrated

Pull up a IE in the the client machine and try browsing the SCP url ur getting in the auto config output

let me know what happens
0
 
snagsy1980Author Commented:
the dirctory security settings are as you suggested. i get an http 403 forbidden status code when i try to browse to the SCP
0
 
Ahmed786Commented:
Have u restarted IIS ? if no then please restart it and check, as after running my first command ISS needs to be restarted
0
 
snagsy1980Author Commented:
yes i restarted the IIS admin service
0
 
MegaNuk3Commented:
Ensure you are on SP3 for Exchange 2007. Is this SBS2008 or not?

Have a read of my article (which was written for non SBS)
http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/A_4962-7-Steps-to-AutoDiscover-Heaven.html

Sounds like 'Authenticated Users' don't have Read on the autodiscover folder.
0
 
Ahmed786Commented:
If after restarting IIS doesn't resolves then please follow below steps.


Adding dns server  a host record.
Host record name must be autodiscover and give exchange server ip
0
 
MegaNuk3Commented:
If you want to bypass the SCP you can add a DNS SRV record:
http://support.microsoft.com/kb/940881

But I don't think this is your issue as the SCP is returning a URL. you just need to get the URL working
0
 
snagsy1980Author Commented:
legend, this guide is very good!
0
 
MegaNuk3Commented:
Thanks for liking my guide. Is your issue sorted now? Was it the NTFS permissions?

Xoxo
0
 
snagsy1980Author Commented:
yes its sorted, not sure if it was ntfs as i followed the guide from start to finish!
0
 
MegaNuk3Commented:
Oh, OK. So you did the complete reset? Glad it worked for you.
0
 
MegaNuk3Commented:
Ignore the 'xoxo' I was typing an SMS to my wife at the same time... Oops
0
 
snagsy1980Author Commented:
hey we are all engineers in love lol
0
 
MegaNuk3Commented:
Lol
In love with IT
Certainly has it's ups and downs like any relationship...
0
 
snagsy1980Author Commented:
me too, it has more downs where i work lol
0
 
MegaNuk3Commented:
Change jobs ;-)
0
 
snagsy1980Author Commented:
excellent advice, just so happens i got a new job yesterday, awaiting contract!
0
 
MegaNuk3Commented:
Good luck and congratulations...
0
 
snagsy1980Author Commented:
thank you sir, happy easter :)
0
 
MegaNuk3Commented:
No need to call me sir... I haven't been knighted yet.

Have a good Easter too.
0

Featured Post

Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

  • 10
  • 9
  • 6
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now