Ubuntu Server Install On IBM e server - installed fine but wont boot

OK..Gurus
I just got an IBM X235 eserver. Decided I really want to stick with Ubuntu as my file server O/S as my old file server has been running superb for about 4 years.

This IBM has a LSI SCSI controller and attached to this I have two Ultra320 drives as a RAID1 mirror config. All seemed to install great but upon reboot I got the
attached screenshot message.. Although I had the last server 4 years I still class myself a novice so any advice please make simple & step by step if poss !! Thanks Folks

John
DSCF0410.JPG
LVL 1
mrmad1966Asked:
Who is Participating?
 
mrmad1966Connect With a Mentor Author Commented:
Seems all three SCSI drives were duff. Two well duff & the third was intermittent hence the reason I was able to install but unable to access after that.... I have since disposed of all three drives & used an IDE and all seems to be running fine !!
Thank you for your efforts though ..
0
 
magwmCommented:
try pressing esc while booting and see the grub configuration. chances are the UUID is not correct or it cannot read it. the LSI controller should not matter as it just presents the disk transparently.

It is relatively easy to boot GNU/Linux from GRUB, because it somewhat resembles to boot a Multiboot-compliant OS.

   1. Set GRUB's root device to the same drive as GNU/Linux's. Probably the command find /vmlinuz or similar can help you (see section find).
   2. Load the kernel:

      grub> kernel /vmlinuz root=/dev/hda1

      If you need to specify some kernel parameters, just append them to the command. For example, to set @option{vga} to `ext', do this:

      grub> kernel /vmlinuz root=/dev/hda1 vga=ext

      See the documentation in the Linux source tree for the complete information on the available options.
   3. If you use an initrd, execute the command @command{initrd} (see section initrd) after @command{kernel}:

      grub> initrd /initrd

   4. Finally, run the command @command{boot}


see http://www.linuxselfhelp.com/gnu/grub/html_chapter/grub_4.html
0
 
mrmad1966Author Commented:
OK.. thanks for this, definatley a step forward. Unfortunatly pressing esc does not allow me to see  the grub config however by commenting out the UUID in /etc/fstab does allow the computer to boot to a login prompt, but my remaining question is how can I confirm all is still working as intended  ???
Thank you
0
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
mrmad1966Author Commented:
Sorry, spoke to soon... on a reboot still dropped to the initramfs prompt :-(
0
 
svsCommented:
might be a case of missing controller firmware -- look for kernel messages mentioning this
0
 
mrmad1966Author Commented:
Is it not logical to assume that had Ubuntu not been compatible with this intergrated LSI SCSI controller it a. Would not have installed successfully in the first place and b. Not given a warning that it was incompatible in some sort of way. ?
0
 
svsCommented:
It is (logical to assume and all that).

Did you see any messages mentioning firmware?
0
 
mrmad1966Author Commented:
Can you advise on how to access the kernal messages from the initramfs prompt please ?
thanks
0
 
svsCommented:
Run a
dmesg

Open in new window

command.
0
 
mrmad1966Author Commented:
Seems all three SCSI drives were duff. Two well duff & the third was intermittent hence the reason I was able to install but unable to access after that.... I have since disposed of all three drives & used an IDE and all seems to be running fine !!
Thank you for your efforts though ..
0
 
mrmad1966Author Commented:
The IBM serverguide software identified the problem..
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.