Downgrade from IOS 4.3.2 to 4.3

Since upgrading past 4.3, my Iphone 4 has become really unreliable. Its been crashing apps for fun and the interface lags/locks for a few seconds at random times.

I've wiped it and started from scratch with a clean install (no backup restores) and its still acting like above

Its got to the point where I want to roll back to 4.3 which worked great.

I've tried this ... http://www.redmondpie.com/downgrade-ios-4.3.1-to-ios-4.2.1-4.1-4.3-4.0.2-4.0.1-iphone-4-3gs-ipad-2-ipad-ipod-touch-how-to-guide-tutorial/

... but it wont let me install the 4.3 firmware. It tries and then fails with an error 3914 i think. I've tried on my desktop and laptop with latest 10.2.2 itunes.

Can anyone help me get back to 4.3?
LVL 1
tribzAsked:
Who is Participating?
 
jonahzonaCommented:
SHSH Blobs will be necessary to make this happen. Apple signs all of their iOS files now, and in order to roll back you will need to have saved your SHSH blobs through Cydia (if you are jailbroken) or through an app called TinyUmbrella.

They did this to stop exploits from being used over and over again.

They only continue to sign an OS for a few days after the new one is rolled out. So unless you have saved these, you are out of luck. Sorry!
0
 
c0sCommented:
did you change the host file?
0
 
c0sCommented:
you hopefully have those saved in cydia
0
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
tribzAuthor Commented:
Hi, yes I did the hosts files but I didnt know to save anything else. I'm not jail broken so I guess I'm out of luck.

Could I jailbreak and roll back? I'm not real sure I want to jailbreak at the moment as Im not sure I want to play cat and mouse with updates etc. Like to keep it simple.
0
 
jonahzonaCommented:
Unfortunately you can't jailbreak and roll back because Apple is no longer signing 4.3, so you can't get your SHSH blobs anymore.

Looks like you are stuck at 4.3.2. You MIGHT be able to restore to 4.3.2 and then get blobs for 4.3.1 through TinyUmbrella (without jailbreaking) and then rollback to 4.3.1.

If they are still signing 4.3.1 that is. Sorry man.
0
 
tribzAuthor Commented:
Okey thanks guys. I'll stick at 4.3.2 stock no apps for now and hope for an update soon
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.