• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 499
  • Last Modified:

Profiles on 2003 Terminal Server

Is there a way to have a new profile loaded every login on a 2003 Terminal Server (i.e delete the old profiles every night)?  We are using local profiles but I could switch to roaming if that would help.  I've been testing with a GPO using the Delete Cached Copies of Roaming Profiles but it doesn't seem to be deleting the profile.
0
DDassow01
Asked:
DDassow01
  • 8
  • 4
1 Solution
 
Justin OwensITIL Problem ManagerCommented:
It will only delete a profile if it is roaming, which it seems yours are not.  You can script a deletion, if you want to, but I would recommend moving to a Roaming profile instead.

DrUltima
0
 
DDassow01Author Commented:
I should have put that in there.  I did create a test user with a roaming profile and it wasn't working.  I added the TS computer so the GPO would apply to it.
0
 
DDassow01Author Commented:
Just checked to make sure the policy is being applied and according to gpresult.  I made a Profiles folder and shared it out with Full Admin access.  If I delete the test profile manually, it recreates the next time I log in but it won't do it automatically.  I will reboot the server in a little but to see if that fixes it.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
DDassow01Author Commented:
Not sure where the rest of my sentence went, but according to gpresult it is being applied correctly.
0
 
DDassow01Author Commented:
Reboot didn't fix it.
0
 
jonahzonaCommented:
We have roaming profiles where I work, and all profiles are deleted the second the user logs off. This prevents the users from accessing corrupted profiles on accident.

This is done through a GP.

Here it is:

Computer Configuration -> System ->User Profiles->Delete Cached copies of Roaming profiles.

Obviously this will only work with roaming profiles, but I can attest that it does work. Wonderfully, actually.
0
 
DDassow01Author Commented:
I think I see the issue.  This is deleting it from the local computer.  I need it to delete the roaming profile from the Terminal Server after they log off.
0
 
jonahzonaCommented:
If you use roaming profiles, you can create a OU and put the terminal server in that OU. Create a GPO for that OU. Apply prior mentioned GP setting to delete roaming profiles. When the user logs off the TS, their profile will be deleted off the server.
0
 
DDassow01Author Commented:
I created an OU called Terminal Server and put this TS in it.  Made a new GPO called Terminal Server GPO and Enforced and Link Enabled it.  Set the Computer Configuration -> System ->User Profiles->Delete Cached copies of Roaming profiles.  Verified thru gpresult that it is using the Terminal Server GPO.  Still won't delete the profile.  
0
 
jonahzonaCommented:
Is the profile a roaming profile? I thought youvsaid they were local profiles. This fix will only work if you are using roaming profiles.
0
 
DDassow01Author Commented:
I have a roaming profile setup as a test.
0
 
jonahzonaCommented:
Have you Restarted since applying the new GPO? This may be a dumb question. I use this particular GP setting for 200 users everyday, so I know it works.
0
 
DDassow01Author Commented:
I was still missing one little part.  In the GPO I didn't "Set Path for Roaming TS Profile."  Once I had that set it did correctly delete the profile from the server!  Thank you for the help.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 8
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now