i cant debug a website in visau studiol 2010

i am working on a website that is very large and has a lot of c# code.
 I can run the website by clicking on the ..aspx page in the solution explorer but
every time i try to debug the website visual studio vs blows up and restarts.there is an error message "Microsoft visual studio has stopped working a problem cause the program to stop working correctly Windows will close the program and notify you if a solution is available" . ?its uses SQL and it is running when i try to run the website.
bdavid35Asked:
Who is Participating?
 
bdavid35Connect With a Mentor Author Commented:
i solved this problem with a friend
0
 
databoksCommented:
Try looking in the event viewer for further errors and post it here.
0
 
sumerdaiCommented:
Can you try disabling your anti-virus program and see if it will allow you to debug? Make sure to reenable it after testing.
0
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
bdavid35Author Commented:
k disabled my  anti-virus program and there was no change.
here is the prints creen of  the  event viewer  print screen of the error viewer
0
 
databoksCommented:
Try repair or uinstall VS2010
0
 
Carlos VillegasFull Stack .NET DeveloperCommented:
Please show the last lines of that event data
0
 
sumerdaiCommented:
This error seems to indicate that there is an invalid operation exception in the Visual Studio program itself.  You should make sure that you have applied all updates for VS. If that doesn't help you can also try repairing or reinstalling, like databoks suggested.

Do you have Expression Web installed also? These programs can use some of the same files, so if you do have it installed, please make sure it is updated too.

There also seems to be a known issue with debugging apps upgraded from Visual Studio 2008. If this is the case for you, please try the fix available here:

http://connect.microsoft.com/VisualStudio/feedback/details/556000/vs-2010-hangs-when-debugging-asp-net-3-5-web-application-or-website
0
 
bdavid35Author Commented:
i tried to do a vs2010 repair and it didn't make any difference. I don't have expression web installed
0
 
Carlos VillegasFull Stack .NET DeveloperCommented:
Hi, please provide your full event data, like the last image that you posted, but full, the last one cut the text at the end.
0
 
bdavid35Author Commented:
i know there  is an error in my code that is why i'm trying   to debug it.
 under the debugging it blew before it it get to the problem code.
i didn't upgrade from vs2008 i just installed vs2010.
0
 
sumerdaiCommented:
There may indeed be an error in your coding, but it sounds like the error you are running to is in the actual Visual Studio environment, not in your code.

In the image you posted, there is a second error which occurred at the same time - for  Asp.Net 4.0.30319.0. Can you please provide the information for this error message?

Also, are you debugging managed or unmanaged mode?
0
 
sumerdaiCommented:
Hi - just wanted to check in and see if you were still experiencing this issue or if it has been resolved. Please let us know if we can continue to be of assistance.
0
 
bdavid35Author Commented:
I solved this problem with a friend
0
 
sumerdaiCommented:
Could you please let us know how you resolved the issue? It may be helpful to future readers.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.