• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 235
  • Last Modified:

problems with setting up appointments

Hello
   I am having a problem with outlook and I think it is a compatibility issue.  The problem is that when making appointments no one can my schedule.  This problem is only happening on my machine.  I am using Outlook 2007 and everyone else is using 2003 so I think that this is the problem.  Is there a way to allow others to see my calendar?
0
dillonconsulting
Asked:
dillonconsulting
  • 23
  • 19
  • 2
  • +2
1 Solution
 
Raheman M. AbdulCommented:
0
 
dillonconsultingAuthor Commented:
We tried to install the Service pack but it is already on the system
0
 
Jon BrelieSystem ArchitectCommented:
Make sure that you are actually publishing your free/busy information under Tools->Options->Calendar options-> Free/Busy Options
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
dillonconsultingAuthor Commented:
Enphyniti:
  I checked and 2 months of his calendar is published and it updates every 15 minutes.  
0
 
cblappCommented:
Have you checked your sharing permissions?  Open your calendar and right-click the Calendar under "My Calendars".  From the menu, choose "Change Sharing Permissions".

That will open the Permissions tab in the Calendar Properties box.  Change your Default setting to "Reviewer".  This will allow everyone to see your meeting schedule, but anything you mark as Private will not be seen.

You can limit what that class of users can do with the check boxes in the Permissions section.  You need to give them access to the folder (Folder Visible Checkbox in Other), and you will want to five them access to the details if you want them to know where you are so they can assess whether you can be contacted while you're in a meeting, but you should set Delete Items to None and not check any boxes in the Write section.

You can have multiple classes with different access levels to your calendar, so perhaps people on your team or your admin will have more permissions than the default.
0
 
dillonconsultingAuthor Commented:
cblapp:

Ok that makes a lot of sense.  It was not set as a reviewer.  I changed that but I am still waiting to see if it worked or not.  
0
 
Jon BrelieSystem ArchitectCommented:
@cblapp - Free/Busy information is actually stored in the public folder database and does not require any additional permissions when published.

0
 
Jon BrelieSystem ArchitectCommented:
What version of Exchange are you using?
0
 
dillonconsultingAuthor Commented:
It is exchange 2003
0
 
Jon BrelieSystem ArchitectCommented:
Did you use outlook 2003 previously?  Try starting your 2007 client with the /ClearFreeBusy flag.
0
 
dillonconsultingAuthor Commented:
The problem is happening now with people that are using outlook 2003 as well.  How do I start outlook with that flag?

Assuming that is does work with that flag how do I ensure that the schedule will work without having to use it?
0
 
Jon BrelieSystem ArchitectCommented:
Just make a shortcut to outlook.exe and include the flag at the end.

If it works, you should just have to do this for each user whose free/busy time isn't showing.
0
 
dillonconsultingAuthor Commented:
Enphyniti:
That is not going to be an appropriate solution I need something that does not require that kind of maintenance we have hundreds of users at our company.  With a group policy script that is already way to long.  

0
 
Jon BrelieSystem ArchitectCommented:
Did you try it?  Did it work for one user?

That would provide us with more information with which to diagnose the issue.
0
 
dillonconsultingAuthor Commented:
Am I supposed to open outlook like this from the outlook account that does not have a visible schedule or from the outlook account that is trying to schedule the meeting?

I tried to open it typing

outlook.exe /ClearFreeBusy from the run command but that doesn't work.  
0
 
dillonconsultingAuthor Commented:
oh wait I see the problem it is clean not clear that you need to type
0
 
cblappCommented:
That's the command.  You shouldn't need to run it every time you open Outlook, but it also won't hurt to do so.
0
 
dillonconsultingAuthor Commented:
opened outlook with that flag but the calendar is still not displaying.  I tried it from an outlook client that has a visible schedule and one that does not have one but some people's calendar's are not shown.  
0
 
Jon BrelieSystem ArchitectCommented:
Has anything changed recently on the Exchange server?  Check your SCHEDUKE+FREEBUSY public folder to ensure that all users can see and modify it.
0
 
dillonconsultingAuthor Commented:
I logged into exchange and the folders I have are
Global Settings
Recipients
Administrative Groups
Tools

There is one called public folders in the Administrative Groups section but there is no folder called Schedule + Free Busy
0
 
Jon BrelieSystem ArchitectCommented:
You need to right click on Public Folders and select "view system folders"

That will allow you to check properties on your free/busy folder.

http://technet.microsoft.com/en-us/library/aa997491%28EXCHG.65%29.aspx
0
 
dillonconsultingAuthor Commented:
When I open that folder I just get a window that opens with a General Tab
In that general Tab there is something called "No properties available on this object"
0
 
Jon BrelieSystem ArchitectCommented:
If you're getting that, you are not clicking in the right place.  Please double check the link provided and ensure that you are following those steps exactly.
0
 
dillonconsultingAuthor Commented:
I am clicking that link!   Can I please have another person look at this? This is becoming a serious problem
0
 
Jon BrelieSystem ArchitectCommented:
Your request has already been made.

I was simply stating that we are talking about basic features of exchange 2003.  (assuming you are running ESM as an administrator).  If you are not seeing what I described, then you are in the wrong place.  The link provided states:

In Exchange System Manager, you can view the system folders for a specific public folder tree by right-clicking the public folder tree node, and then clicking View System folders.

Note that you find the public folder tree node under: (Exchange)-Administrative Groups-<your admin group>-Folders-Public Folders.  (right click on that last one, select view system folders and expand)

If you really do not have this, then your exchange 2003 installation is seriously broken.
0
 
dillonconsultingAuthor Commented:
Enphyniti:
  I assure you I am in the ESM  

 ESM
This is how I am accessing the Schedule + Free Busy folder

When I check the properties of the Schedule + Free Busy from the right hand pane it reads "No properties available on this object"

There is a separate folder in the Schedule + Free Busy folder which has a LDAP path which tells me that it is unique to our organization.

In this folder I can access the properties such as replication.  It is running and it is working just not for any of the new accounts that I have created or for any of the new calendar items that I have put in the public folders section.  

It is also listed on the left hand pane and when I right click on it in there there there is a different set of options.

Do you know what I need to check in here to make the new calendars schedule visible?

There is however a folder inside that is specific to our organization
0
 
Jon BrelieSystem ArchitectCommented:
My mistake.  From your response I misunderstood that you were still having trouble viewing system folders.

Now that you are in there, you should be able to right click on the folder with the LDAP properties you described and view permissions from there.  Your default permissions should be Editor. (client permissions)

You also want to make sure that all of your users are displaying properly in the Default Global Address List.  If any are missing, or if permissions have been changed there, it could be causing the issue.

One thing to try would be to add an affected user explicitly as an editor to your free/busy folder and see if that changes anything.
0
 
dillonconsultingAuthor Commented:
I added someone to the client permissions list and made them an editor, but I still can not see their Calendar.
I know that our GAL updates once a day. Does that mean that this change will take a day to complete and replication happens once a day?
For some reason I can't see  when it replicates on here.
0
 
Jon BrelieSystem ArchitectCommented:
No, you shouldn't need to wait for it if the user is already in the GAL.  Only if you added them.

Additional troubleshooting tips:

http://exchangeserverinfo.com/2009/08/28/troubleshooting-freebusy-issues-in-exchange-2003-server.aspx
0
 
dillonconsultingAuthor Commented:
I checked this troubleshooting Guide but I am having a problem with step 6.  I checked the content tab and did not see the test appointment I made in there.  But the info in the content tab does not make much sense to me because there is hardly any information in there at all.  Is there supposed to me a log for all the appointments made from people to our organization in there?
0
 
Jon BrelieSystem ArchitectCommented:
You should be able to search in the content section (use the magnifying glass on the Content tab, not the find tab).

Search subjects for your user's username in capital.

You could also try the rest of the troubleshooting methods without necessarily confirming this one.
0
 
dillonconsultingAuthor Commented:
I did the search like you suggested and I was able to find users that don't have an published calendar in the Free-Busy folder.  

I am trying the other steps now but I would like to know what I would need to do if the problem is that Exchange is not replicating properly.  

Would there be some reason that some users calendars would replicate when others don't even if there names show up in the Free Busy folder?
0
 
dillonconsultingAuthor Commented:
because Step 8 can corrupt your free/busy information. I am not willing to try this step.  
0
 
Jon BrelieSystem ArchitectCommented:
How many exchange servers are you replicating public folders to?

Does the server upon which a mailbox resides have any impact on which users' free/busy information you can see from that mailbox?
0
 
dillonconsultingAuthor Commented:
We have 1 exchange server.  
0
 
Jon BrelieSystem ArchitectCommented:
Take a look at this link: http://answers.microsoft.com/en-us/windows/forum/windows_vista-networking/windows-mail-to-qcom-addresses-gets-rejected/46e2a97c-69e8-4999-bba8-425ff330905f

Make sure that the DN matches for adminGroup\SiteFolderServer and pubFolders\DistinguishedName.

Let me know if they do not.

Also, try sending a test appt to another user and have them accept it.  Are you able to see FB info after they accept?
0
 
Jon BrelieSystem ArchitectCommented:
Oh, and don't worry about a replication issue.  If you only have 1 exchange server, you aren't replicating anywhere.
0
 
dillonconsultingAuthor Commented:
It looks like the problem is that the free/busy data is not publishing for users that had their account created in the last 3 months.  I checked the free/busy system folder on the ESM but there is no info there for most of the users.  Is there a way to force exchange to publish this data?
0
 
Jon BrelieSystem ArchitectCommented:
Did anything change around then?  How are you provisioning users?  Via script?  Copying another?
0
 
dillonconsultingAuthor Commented:
I am creating users with a script.  I have been using this script for the past year.  The only thing that is different is that I am using windows 7 now.  I ran the script from the exchange server but the free busy data is still not there.  
0
 
Jon BrelieSystem ArchitectCommented:
What if you manually create a user on your exchange server.  Does it work then?  Does the change in user behavior coincide with the date you switched to Windows7?
0
 
dillonconsultingAuthor Commented:
Manually creating the accounts does work.  

I did lots of testing and I found out what the problem is though I am not sure why it started happening when it did.

In my script for creating accounts I added this line

'objUser.Put "msExchHomeServerName", "/o=Ourcompany /ou=exchangeGroup/cn=Configuration/cn=Servers/cn=EXCHSERVER"

This line is not correct and the /ou exchangeGroup section is wrong I don't think we have one with this name

I found out that if I create an account and omit this line the calendar is visible.

Can you tell me how I can move the other account to the correct msExchHomeServerName?
I tried deleting and recreating the mailbox but that didn't work.  I am also trying to just move the mailbox.
0
 
Jon BrelieSystem ArchitectCommented:
You can do it manually with ADSIEdit, or you could use a tool to do it en masse.  One I've used in the past and had pretty good luck with is AD Bulk Users.

http://www.dovestones.com/blog/index.php/category/ad-bulk-users/
0
 
dillonconsultingAuthor Commented:

I checked ADSI edit for the test account I created.  But because I already deleted and recreated the mailbox the msExchHomeServerName is the same.  The Calendar is just not posting in the Free/Busy Folder.  Is there a way to manually add a maillbox to this folder?
0
 
dillonconsultingAuthor Commented:
Well I got it to work by changing some fields with ADSI edit then I re-added outlook.  
0
 
ee_autoCommented:
Question PAQ'd and stored in the solution database.
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

  • 23
  • 19
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now