• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 269
  • Last Modified:

WordPress 3.1 won't create posts

I'm setting up a WordPress 3.1 multiuser site at tours.operationbarnabas.net.  The admin panel is working fine, but when I either create a new blog or post to the main blog, the posts don't create any files for viewing.

The site is setup to use sub-directories for individual blogs and running on a Windows server.

When I visit the root site, I get the error "Warning: require(./wp-blog-header.php) [function.require]: failed to open stream: No such file or directory in C:\...\tours.operationbarnabas.net\wwwroot\index.php on line 17"

.htaccess is in the root with the suggested code from when I setup the network in Wordpress.

If anyone can walk me through this problem, I'd really appreciate it.

Steve

0
stkoontz
Asked:
stkoontz
  • 5
  • 5
1 Solution
 
gwkgCommented:
Where is wp-blog-header.php in relation to index.php?

Maybe change

require('./wp-blog-header.php');

to

require('wp-blog-header.php');

in index.php
0
 
stkoontzAuthor Commented:
Thanks for the reply.

That worked to get the main site working.  (tours.operationbarnabas.net)  But do you have any suggestions for getting the individual blogs working?

Thanks,

Steve
0
 
gwkgCommented:
Are they giving you the same error message?
0
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
stkoontzAuthor Commented:
There's no real error message.  The individual blog files aren't being created on the server.

My Windows webhost doesn't recognize .htaccess files.  I've tried using web.config files to get WordPress to create the folders and files, but can't get it to work.

I received these responses from my webhost tech support...

.htaccess files are not recognized.  The issue is wordpress attempting to rewrite urls and the web server not being able to process those rewritten urls.  

Your wordpress blog is trying to rewrite URLs. This won't work without the URL rewritng filter installed. Disable the URL rewriting from within the wordpress settings.

I tried to find a setting in Wordpress to disable the URL rewriting, but couldn't.

Thanks for coming back in to help.  I appreciate it.

Steve
0
 
stkoontzAuthor Commented:
I've found posts saying that multiuser Wordpress 3.0 is very difficult to get running on a Windows server.  I'm going to go back to single user mode until Wordpress comes out with a release that's easier to get running on a Windows server.

I appreciate the effort, though.

Steve
0
 
gwkgCommented:
From now on you might want to mention that you have a windows install when asking wordpress questions.

I'll also try to remember to start asking =)
0
 
stkoontzAuthor Commented:
Thanks for the lauragentry.com link.  It helped me understand the problem.  My webhost won't install IIS URL Rewrite 2.0.

My initial post does mention that I'm on a Windows server.  Should I have clarified it more by saying the Windows server is running IIS?

Thanks again for the help.

Steve
0
 
stkoontzAuthor Commented:
Suggested solutions didn't solve the problem I have.
0
 
gwkgCommented:
No, that's fine... I just read right past it!
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 5
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now