• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1281
  • Last Modified:

Robocopy not working

I am trying to move files (and retain all permissions, etc..) between Windows Server 2008R2.

I have a test directory that I am trying to move from F: to X:

When I run the command from an administrator command prompt, I just get the same command line repeating until I hit CTRL-Z to kill the batch job. It is not a batch job, just me copying and paste the one line below in the window.




robocopy f:\testdir     x:\          /s /e /copyall /move /zb /R:0 /W:0

Open in new window

Capture.PNG
0
freshgrill
Asked:
freshgrill
  • 6
  • 6
1 Solution
 
KeterHDCommented:
Try running it as robocopy.exe with the parameters.
0
 
freshgrillAuthor Commented:
@keterhd: Okay, it now shows a screen but hangs without actually coping the testdir. The testdir, has 1 other sub-directory, then other sub-directories and files. The entire directory < 30 MB.

 Screen Shot
0
 
KeterHDCommented:
Well, first, attempt to copy the data using only the very basic switches (forget about ACLs and such - just try the very basic copy process). BTW, as far as I can see, /s switch copies all dirs except empty ones, while /e switch copies all and empty ones. Try removing one of them and see if they're conflicting.
0
Granular recovery for Microsoft Exchange

With Veeam Explorer for Microsoft Exchange you can choose the Exchange Servers and restore points you’re interested in, and Veeam Explorer will present the contents of those mailbox stores for browsing, searching and exporting.

 
freshgrillAuthor Commented:
Okay, it appeared to copy it. But when I got to x: drive it is not there. If I run the command again, it says that the files are already there - but when I check there is no "testdir" of x:

Below is what I get.
F:\>robocopy.exe f:\testdir     x:\          /e

-------------------------------------------------------------------------------
   ROBOCOPY     ::     Robust File Copy for Windows

-------------------------------------------------------------------------------

  Started : Fri Apr 22 09:13:02 2011

   Source : f:\testdir\
     Dest : x:\

    Files : *.*

  Options : *.* /S /E /COPY:DAT /R:1000000 /W:30

------------------------------------------------------------------------------

                           0    f:\testdir\
        *EXTRA Dir        -1    x:\$RECYCLE.BIN\
        *EXTRA Dir        -1    x:\711\
        *EXTRA Dir        -1    x:\Accounting\
        *EXTRA Dir        -1    x:\Archived\
        *EXTRA Dir        -1    x:\Backup\
        *EXTRA Dir        -1    x:\Brown Bag\
        *EXTRA Dir        -1    x:\CDC\
        *EXTRA Dir        -1    x:\Chefs\
        *EXTRA Dir        -1    x:\Data\
        *EXTRA Dir        -1    x:\Deployment\
        *EXTRA Dir        -1    x:\Drivers\
        *EXTRA Dir        -1    x:\Linda\
        *EXTRA Dir        -1    x:\network\
        *EXTRA Dir        -1    x:\Operations\
        *EXTRA Dir        -1    x:\Public\
        *EXTRA Dir        -1    x:\QA\
        *EXTRA Dir        -1    x:\QA - IT Reporting\
        *EXTRA Dir        -1    x:\QB\
        *EXTRA Dir        -1    x:\Radman\
        *EXTRA Dir        -1    x:\RECYCLER\
        *EXTRA Dir        -1    x:\Sales\
        *EXTRA Dir        -1    x:\Scans\
        *EXTRA Dir        -1    x:\System Volume Information\
        *EXTRA Dir        -1    x:\temp-delete later\
        *EXTRA Dir        -1    x:\Users\
        *EXTRA Dir        -1    x:\websites\
                           3    f:\testdir\Canon 2870\
                          11    f:\testdir\Canon 2870\misc\
                           1    f:\testdir\Canon 2870\misc\ANIMIMG\
                           1    f:\testdir\Canon 2870\misc\DDI\
                           1    f:\testdir\Canon 2870\misc\DDI\canon_lpr_port\
                           1    f:\testdir\Canon 2870\misc\DDI\XML\
                           0    f:\testdir\Canon 2870\usbport\
                           5    f:\testdir\Canon 2870\usbport\win98\
                           2    f:\testdir\Canon 2870\usbport\winme\
                          78    f:\testdir\Canon 2870\win2k_xp\
                          95    f:\testdir\Canon 2870\win98_me\

------------------------------------------------------------------------------

               Total    Copied   Skipped  Mismatch    FAILED    Extras
    Dirs :        12         0        12         0         0        26
   Files :       198         0       198         0         0         0
   Bytes :   22.55 m         0   22.55 m         0         0         0
   Times :   0:00:00   0:00:00                       0:00:00   0:00:00

   Ended : Fri Apr 22 09:13:03 2011

Open in new window

0
 
Sean MeyerCommented:
Use rich copy instead... give you a GUI  -- newer version of Rich Copy and easier to use.

http://technet.microsoft.com/en-us/magazine/2009.04.utilityspotlight.aspx

0
 
KeterHDCommented:
Well, if I understand correctly, you copy all data from f:\testdir into x: . I don't really know robocopy, but AFAIK it wouldn't create a folder named 'testdir' on X. Instead, it would copy all files from testdir into the root of drive X. Can you make sure the files aren't there?
0
 
freshgrillAuthor Commented:
@keterhd: Yes, it didn't copy the files to the root directory of X.

@armygroo: I will have a look at richcopy.
0
 
KeterHDCommented:
Hm, kinda weird.

Okay. Is X an actual drive or a folder mapped to a drive? Is there a memory stick or an external HDD connected to the PC?
0
 
freshgrillAuthor Commented:
@armygroo: Still not working, I download and selected move.

Now on X: still is no directory on F: under testdir is empty directories only - all files gone and richcopy gave the message:
4/22/2011 9:55:51 AM,2,The system cannot find the file specified.
,X:\Canon 2870\win2k_xp\irc408su.up_
0
 
freshgrillAuthor Commented:
@keterhd: X is a mapped drive to another Windows server 2008R2
0
 
KeterHDCommented:
Okay. You say that the files are not located on X:. How do you view them? Do you view the contents of X through Windows Explorer or from the command prompt? Can you attempt to go to the share, instead of the drive letter? For example, \\server01\sharex?

The reason the files are gone might be that on one occasions you might've used the move switch (from what I can see on a screenshot you posted beforehand), which might've actually moved the files instead of just copying them.

Could you right-click the My Computer icon, and go to Manage? Then go to Disk Management. In the right (larger) side of the window, see if you have an X drive in the list. Do you have one?
0
 
freshgrillAuthor Commented:
@keterhd: Thanks, I finally got it to work by using UNC paths and specifying a directory name for the target also. More work, but it works.
0
 
KeterHDCommented:
Haha, I was soooo close to proposing it :) Have a great time.
0

Featured Post

Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

  • 6
  • 6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now