email still getting into junk folder

i asked the question earlier but it still seems to be happening. at this point, how can i just disable the junk folder altogether ?
my domain, abc.com, some emails are being directed to the junk folder, some are not. when i right click on the email in the junk folder and choose junk mail options, i added *.abc.com to the safe senders and safe recipients list. then in the options, i chose "safe list only". something is not working here.
miamiLAWAsked:
Who is Participating?
 
nexusdsCommented:
on the home tab, pul down Junk, Junk Email options, you should be able to disable it there.
0
 
miamiLAWAuthor Commented:
choose "no automatic filtering."
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.