• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2954
  • Last Modified:

Backing up Cisco asa 5505 config

hello and thank you for your time.

I am still new to the cisco asa 5505 and im trying to back up the configurations.  i located the command in the cisco KB "hostname# copy {startup-config | running-config} tftp://server[/path]/filename"

i have entered this command "hostname# copy {startup-config | running-config} tftp://10.0.0.49/C:\TFTP-Root/config" and I am receiving these results

hostname# copy {startup-config | running-config} tftp://10.0.0.49/C:\TFTP-Root/c        ^onfig

ERROR: % Invalid input detected at '^' marker.

Can some one tell me what I am doing wrong ?

Thanks again
0
jrojas1213
Asked:
jrojas1213
  • 8
  • 7
  • 2
1 Solution
 
Ken BooneNetwork ConsultantCommented:
type in this:

copy run tftp

When you hit enter it will prompt you for the following:

Source filename [running-config]?     - just hit enter
Address or name of remote host []?  -  10.0.0.49
Destination filename [running-config]? - type in whatever you want the filename to be called i.e. asaconfig.txt

Thats all you need.


0
 
jrojas1213Author Commented:
I tried that initially and this is what I received

 screen shot
0
 
Ken BooneNetwork ConsultantCommented:
You need to do this from the CLI directly not from the GUI access to the CLI.  Telnet or ssh into the box and do this.
0
SMB Security Just Got a Layer Stronger

WatchGuard acquires Percipient Networks to extend protection to the DNS layer, further increasing the value of Total Security Suite.  Learn more about what this means for you and how you can improve your security with WatchGuard today!

 
Ken BooneNetwork ConsultantCommented:
Im sure there is a way from the gui as well but I hardly ever use it.  
0
 
jrojas1213Author Commented:
that is all i know how to use because the consultant who use to take care of the company has the password and he has the password to telnet in and he is difficult to get a hold of
0
 
Ken BooneNetwork ConsultantCommented:
then try this:

copy run tftp://10.0.0.49/asaconfig.txt
0
 
jrojas1213Author Commented:
same results
0
 
Ken BooneNetwork ConsultantCommented:
from the ASDM
click on file
then click on "Save running-config to tftp server..."

Then should be good to go.
0
 
jrojas1213Author Commented:
I get this when running it

copy /noconfirm running-config tftp://10.0.0.49/C:\TFTP
      Cryptochecksum: b282ad5f 0fc9c77a d11de382 e06724f5
!!!!!
%Error writing tftp://10.0.0.49/C:\TFTP (Bailing out to bad characters in filename: "C:\TFTP".)

I enabled TFTP Client in device management, and entered the same parameters of IP and file location.  I renamed the file location because I am not sure what is meant by "bad characters in file name"
0
 
Ken BooneNetwork ConsultantCommented:
Do it from the gui.

Click on file then save running-config to tftp server

It then prompts you for tftp server and filename

just specify the ip as 10.0.0.49

then specify just the filename you want to call it.  as in asaconfig.txt


thats it.

make sure your tftp server is set up to the home directory of where you want the file to go.
0
 
Mystique_87Commented:
Did you try copying from the ASDM:
Keep a PC ready with a TFTP server software running(like TFTPd 32).
Check the connectivity between the PC and the ASA, using ping.
In the ASDM, Go to file->Save Running Config to TFTP server
enter the PC's ip and the directory where the configuration needs to be stored.

Hope this helps
0
 
jrojas1213Author Commented:
yes i installed solarwinds a free TFTP and the service was running so I know it was active
0
 
jrojas1213Author Commented:
I finally got the password to telnet in.  after that it worked like a charm.  Thanks for your help.  is there a command to change the password in telnet.
0
 
Ken BooneNetwork ConsultantCommented:
so when you telnet in is it prompting you for a username or just a password.  It makes a difference in the answer to your question.
0
 
jrojas1213Author Commented:
it prompts for a password
from what I was taught briefly a long time ago was to enter the password.  it showed the host name I typed "EN" and then typed a different password.
0
 
Ken BooneNetwork ConsultantCommented:
yea the command for the password is

passwd xxxxxxxx

where xxxxx is the password

then the enable password is changed by doing this

enable password xxxxxxx
where xxxxx is the password

0
 
Mystique_87Commented:
Sorry about the previous post.
point your TFTP server to the directory where you would like to store the file.
Just enter the name of the file you would like to save the configuration as
0

Featured Post

Will You Be GDPR Compliant by 5/28/2018?

GDPR? That's a regulation for the European Union. But, if you collect data from customers or employees within the EU, then you need to know about GDPR and make sure your organization is compliant by May 2018. Check out our preparation checklist to make sure you're on track today!

  • 8
  • 7
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now