• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 794
  • Last Modified:

unable to RDP through Linksys WRT54G router

I have a small office with a few computers configured in a workgroup. Suddenly RDP stopped working from outside the office. I have a Linksys wrt54g router. I setup port forwarding for 3389 tothe ip address of the pc I want to access. RDP works to it internally inside the network.
I can't even Telnet to the 3389 port from outside. Any ideas?
Thanks.
0
raffie613
Asked:
raffie613
1 Solution
 
4e4enCommented:
Make sure that you have TCP AND UDP ports forwarded to 3389 ports, if they are, then try to reboot router and/or computer.

If that doesn't help and you don't care much about security, then you can set up DMZ pointed to your computer.
0
 
activematxCommented:
What is the ip of the pc?  Go to the wrt54g config page, and temporarily go to DMZ and point the pc there.
0
 
michael626Commented:
This tutorial maybe slightly what you want: linksys router usally uses 192.168.1.1
you can use this website as a reference:

http://portforward.com/english/routers/port_forwarding/Linksys/WRT54G/

that's the old style menu but now its slightly the same

sorry for my bad english.
0
A Cyber Security RX to Protect Your Organization

Join us on December 13th for a webinar to learn how medical providers can defend against malware with a cyber security "Rx" that supports a healthy technology adoption plan for every healthcare organization.

 
QuietFrankCommented:
Just curious, could your public IP have changed. If you go to a site like whatismyip.com, is it the same IP you are trying to RDP into?

Frank
0
 
raffie613Author Commented:
public IP is correct. I have a comcast modem between the Linksys device and the outside. The modem is set for passthrough. Do I set the Linksys in the config options as a gateway for router?
0
 
Brian GeeCommented:
Make sure the computer you are trying to connect to still has the DHCP-issued IP address that you have in your port forwarding setting. If you were able to connect before, then your settings were working which leaves the (static) IP address assigned to you from Comcast, the IP address of the system you're trying to connect to, or you need to powercycle your router as potential places of issue.
0
 
raffie613Author Commented:
the ip for the computer I am trying to get to has a static ip. all this is new since we moved into this new building.
0
 
Brian GeeCommented:
Just to test points-of-failure, have you established internal RDP connections to the computer itself my IP address? If this works, it really is the IP address assigned by Comcast that needs to be confirmed. If all is confirmed as correct, I think a call to Comcast might be in order. I have a couple SoHo clients with your type of setup (Linksys WRT54G, Comcast, RDP, etc.) with no issues -- the only difference being they have dynamic IPs (using dyndns.org for DNS).
0
 
raffie613Author Commented:
ok,
I was able to get in and use RDP once I enabled the DMZ and pointed it to the pc. Any ideas why it isn't working using the regular port forwarding?
0
 
Brian GeeCommented:
The Port Range Forward is set to 3389, 3389, Both, the correct IP address and the Enabled checkbox checked, right?  
0
 
raffie613Author Commented:
yes sir
0
 
raffie613Author Commented:
Still can't RDP to m,ultiple computers. Have to use DMZ
0

Featured Post

Prep for the ITIL® Foundation Certification Exam

December’s Course of the Month is now available! Enroll to learn ITIL® Foundation best practices for delivering IT services effectively and efficiently.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now