?
Solved

ColdFusion 9 installation on Windows 7 64-bit IIS 7.5

Posted on 2011-04-22
13
Medium Priority
?
2,732 Views
Last Modified: 2013-12-24
Hello Experts,

Well, I am at my wit's end, and am so hoping someone will be able to help. I bought a new Dell laptop system about 2 months ago. It is Windows 7 Professional 64-bit with IIS 7.5. I managed to install CF 9 64-bit Developer Edition and all was working ok. After not utilizing my CF for local testing for a couple of weeks, I needed to develop and test a new application about a week ago and discovered that I can no longer access any .cfm pages. I would just get completely blank pages or HTTP 500 Internal Server Errors, depending on the mood of my browser, or even which browser I used. As things were working fine for weeks, and nothing changed on my system, that I am aware of, other than the usual automatic Windows updates, I am wondering if some update corrupted things. I decided to go through the entire process of uninstalling and reinstalling CF 9 and after the initial installation process, when it says to log into CF Administratror, I click the link to do so, and the Administrator will not load. Sometimes it just displays a blank page and when I view the source code, it displays just:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META content="text/html; charset=utf-8" http-equiv=Content-Type></HEAD>
<BODY></BODY></HTML>

Other times the HTTP 500 Internal Server Error comes up. I have searched Adobe Forums and here, Googled at length, but cannot find anyone with the same issue, and I am getting desperate, as I now have a number of CF projects that I need to develop and test locally on my own system before deploying live. I've gone through the detailed steps of uninstalling/reinstalling that I have found online, made sure my virus program and firewall were turned off during installation, made sure IIS had the correct things configured, etc., based on info I had found online from others. If anyone here is able to help, it would be so appreciated.
0
Comment
Question by:tam423
  • 7
  • 5
13 Comments
 
LVL 29

Expert Comment

by:Pravin Asar
ID: 35460104
You need to enable IIS 6 Compatibility Mode.


Look at

http://www.codecurry.com/2009/09/installing-coldfusion-on-iis-7.html
0
 

Author Comment

by:tam423
ID: 35460554
Thank you, but I do have IIS 6 Compatibility Mode enabled, as well as ISAPI extensions, which I understand I also need. Also, I made sure these were enabled prior to the CF re-installation, as I understand that is important, as well. I had previously visited the link that you referenced, as well as any others I could find similar, and I really thought I had all my ducks in a row, as far as what the process needs to be for installation, but I just cannot get into the CF Administrator. It bothers me that I haven't found others with a similar issue, with the same system configuration, as it sounds like it is something unique to my system. But, I am clueless as to what it is or where to look. I was so hoping it was just a setting or something, that I had overlooked, but it's not looking like that.
0
 
LVL 29

Expert Comment

by:Pravin Asar
ID: 35462535
1. First make sure you have full "Administrator" Rights.


2. Try

"Web Server Configuration Tool"

( Under Adobe=>ColdFusion9


3.Run CF Installer as "Administrator"







0
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

 

Author Comment

by:tam423
ID: 35463704
Hello,

1. I checked under User Accounts within Control Panel and it says that I am the Administrator, so I believe I have full Administrative rights.

2. When I go into the Web Server Config Tool, it lists under Configured Web Servers:

[ localhost:coldfusion ] Internet Information Server (IIS) : All

When I click on the Add button, an error message comes up, stating:

"Could not connect to any JRun/ColdFusion servers on host localhost.
Possible causes:
- Server not running
  - Start Macromedia JRun4 or ColdFusion 9 server
- Server running
  - JNDI listen port in jndi.properties blocked by TCP/IP filtering or firewall on server
  - host restriction in security.properties blocking communication with server"

Once I click off of that message, the Add Web Server Configuration screen comes up, but the OK button, in order to add, is grayed out, so it will not allow me to add anything (I'm guessing due to the previous error message that came up). I stopped and restarted CF, then tried again and the above didn't come up and the window to add came up with "localhost" as the JRun Host and "coldfusion" as the JRun Server already selected. I checked the box for "Configure web server for Coldfusion 9 applications" then clicked OK. After a few minutes of waiting for something to happen, a message comes up, stating "An unknown error has occurred".

I'm not sure what most of this means, or what action I am supposed to take, but I did verify that the CF 9 Application Server was started under Services and did try to stop and restart it, as well, and I've tried turning off the Windows firewall, but no change.

3. Do you mean to right-click the ColdFusion_9_WWE_win64.exe installer file and select "Run as Administrator"? If so, would I need to uninstall, etc. everything first prior to taking this action?

Thank you for trying to help me -- I do appreciate it.
0
 
LVL 29

Expert Comment

by:Pravin Asar
ID: 35467929
About

3. Do you mean to right-click the ColdFusion_9_WWE_win64.exe installer file and select "Run as Administrator"? If so, would I need to uninstall, etc. everything first prior to taking this action?


Thank you for trying to help me -- I do appreciate it.


Before reinstalling, definitely you need to uninstall

Follow Control Panel ==> Uninstall Program.

Now do the reinstall CF9.

RMB (Right Mouse Click) on   ColdFusion_9_WWE_win64.exe,  and select "Run as Administrator"



0
 

Author Comment

by:tam423
ID: 35478941
OK, I went through the whole process of uninstalling and reinstalling via "Run as Administrator" and it still does not work. Trying to open the CF Admin just yields either a blank page or an HTTP 500 Internal Server Error message. I didn't really think this would make a difference, as I would think that since I have full administrative rights on this computer, running as administrator during the install would be the same as my previous regular installation by just double-clicking the install file. Anyway, at this point, I think I should try going directly to Adobe and see if they can help, unless you have any other thoughts. Thank you for all of your assistance, though. I do appreciate it.
0
 
LVL 29

Expert Comment

by:Pravin Asar
ID: 35479842

1. At DOS Command prompt

         ping localhost
         ping 127.0.0.1


2. GOTO URLS
 http://127.0.0.1/cfide/administrator/index.cfm
http://localhost/cfide/administrator/index.cfm

3. Make sure CF Services are running

4. Check the Handler Mappings

  You will find this under IIS Manager ->Default Web site.

            Is it adding the handlers for cf (cfc, cfm, cfml)???



0
 

Author Comment

by:tam423
ID: 35480053
I went through each of the items in your list and have attached a .gif file containing screen shots of each thing, so that you can see what I am seeing. CF services appear to be running and the CF handlers appear to be added. If I can provide any other screen shots, I would be happy to. Pictures speak louder than words! Thank you again.  
cf-screenshots.gif
0
 
LVL 29

Expert Comment

by:Pravin Asar
ID: 35480116
Read

http://forums.adobe.com/message/3630400

try it at your Risk

Good Luck

0
 

Author Comment

by:tam423
ID: 35480258
Their problem has to do with uninstalling, which I've had no problem doing -- at least so far (I've uninstalled/reinstalled I don't know how many times now) -- so I'm reluctant to mess with regedit, as advised (and the person hasn't posted back that it worked for them, and it's been almost a week). But, thank you for that link -- I hadn't seen that one (probably because of the post title), and their situation is closer to mine than any others I've seen so far. I did post on the Adobe forums, but no one has helped so far. Their paid phone support may be my only hope, at this point...
0
 

Expert Comment

by:ThomasAHeath
ID: 35894456
Did you install the 9.0.1 patch to Cold Fusion? One of the great features of 9.0.1 is much better compatability with IIS 7.5, including the fact that you no longer need IIS 6 Compatability enabled. But Adobe, in their infinite wisdom, hasn't updated the installer. You still have to manually install 9.0, download the 9.0.1 patch, and then upgrade.
0
 

Accepted Solution

by:
tam423 earned 0 total points
ID: 35915998
Hello Thomas (and pravinasar),

Since I wasn't able to complete the initial installation CF 9, I could never get to the point where I could install the 9.0.1 patch. But, I do appreciate your response, as well as the responses from pravinasar, in an effort to resolve my issue. I did recently -- finally -- get a solution to my problem, via the Adobe forums, and I wanted to post that info here, in case this might help anyone else that might run into this same situation, and to gain closure with this open question here:

Some insight was initially gleaned from the CF application and exception logs, as it showed errors with Java heap and out of memory errors. I then modified the JVM.config file to increase the memory and enable GCOverheadLimit --

-Xms1024m -Xmx1024m
-enable -XX:-UseGCOverheadLimit

I also downloaded and installed the updated JVM (Windows x64 version):

http://www.oracle.com/technetwork/java/javase/downloads/jdk-6u25-downl oad-346242.html

Once it was installed, the path needed to be changed from the default JVM to the new 1.6.0_25 JVM (commenting out the default java.home path):

# Built in 1.6.0_14 Runtime
#java.home=C:/ColdFusion9/runtime/jre

# Java 1.6.0_25 Runtime
java.home=C:/Java/jdk1.6.0_25/jre

I then stopped CF, backed up the log files in the /logs directory to get fresh files (easier to read than searching though for the last message appended) and started CF again.

Just modifying the JVM.config file, as described above did not do the trick for me (I tried just doing that initially), but once I downloaded and installed the updated JVM, etc., I couldn't believe my eyes when I tried logging into CF administrator and it actually opened! I was able to then finish the initial installation and then apply the 9.0.1 update. After doing a final restart, everything worked fine and no error messages were generated in the logs. I went back in to the JVM.config and removed the "-enable -XX:-UseGCOverheadLimit", as instructed, and all still worked fine. I will go ahead and close this open question now.
0
 

Author Closing Comment

by:tam423
ID: 35950918
I appreciate all those here that tried to help. I was able to utimately able to find a solution myself, from another forum. Thank you.
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Introduction This article explores the design of a cache system that can improve the performance of a web site or web application.  The assumption is that the web site has many more “read” operations than “write” operations (this is commonly the ca…
When it comes to showing a 404 error page to your visitors, you do not want that generic page to show, and you especially do not want your hosting provider’s ad error page to show either. In this article, I will show you how to enable the custom 40…
Exchange organizations may use the Journaling Agent of the Transport Service to archive messages going through Exchange. However, if the Transport Service is integrated with some email content management application (such as an anti-spam), the admin…
Is your data getting by on basic protection measures? In today’s climate of debilitating malware and ransomware—like WannaCry—that may not be enough. You need to establish more than basics, like a recovery plan that protects both data and endpoints.…

807 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question