Exchange 2010 FQDN when telnet port 25

Hi,
I am migrating from Ex2003.  In Ex2003 I remember changing the FQDN that was presented when I would telnet to port 25 on the local box. I created a reverse pointer record in DNS that matched the name present in my banner header.
In other words I would telnet to port 25 and it would come back mail.myserver.com. Then I created a reverse PTR record in DNS to point mail.myserver.com back to the IP of my mail server. This was needed because certain mail servers would not accept mail until I did it.
I am having problems doing this in Exchange 2010. I go to Server Config->Hub Transport-> Receive Connectors.  I am not able to put in my FQDN into the Default Connector. The only name it will accept is my local AD domain name (ie  exchange2010.myserver.lcl).  Since this is not a FQDN, how do I enter one in to keep the other mail servers on the net happy?
Hope I was clear on this.

Thanks,
Mike
LVL 1
nachtmskAsked:
Who is Participating?
 
Suliman Abu KharroubIT Consultant Commented:
from organisation configuration, hub transport -->"send  connector" properties -->change FQDN.

a.PNG
0
 
abhijitmdpCommented:
Will you please clearify your needs, as far as I understood your problem you wanted to start your mails from exchange 2010,for this you don't need to modify your default connectors for exchange 2003 bcoz there is an routing group connector automatically been created at the time of coexistance with exchange 2003 and this will start your mail flow from exchange 2010.
0
 
ashok_523Commented:
If you are reffering to the reverse DNS lookup then you need to publish/Set at your ISP level, not your local DNS level.. get in touch with your ISP for that
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
michaelshavelCommented:
Hi,
I'm sorry, I guess I wasn't clear. I don't know the correct terminology. So I will explain better.
I have an Exchange 2010 server. I DID have an Exchange 2003 server but I am taking that offline. I am talking about my Exchange 2010 server and how it communicates with other EXTERNAL servers when making an SMTP connection.

More specifically:
When a mail server connects to another external mail server it often checks what the HELO FQDN name is. You can test what this is by doing a telnet localhost 25. The FQDN that is brought back is what other mail servers will see. This FQDN that is brought back needs to have a reverse pointer entered into DNS of the local ISP (or server provider as in my case: Rackspace). If the FQDN reported by the server in the HELO banner isn't the same as the reverse pointer DN, then the other mail server sometimes will reject the mail.
In Ex2003 it was easy to change what the FQDN was that was reported by the current mail server. All I had to do was going into the SMTP connector and change the name.
In Ex2010 though it doesn't seem to easy. The Receive connectors for Ex2010 have the FQDN as the local AD domain name (in my case mydomainame.lcl) and it's not possible to alter this to the external domain name (mydomain.com).
So my question is, how to I change the FQDN in the HELO on my Ex2010 server that is received by other mail servers trying to make a connection to my server?

Hope that explains it better.
Mike
0
 
FarWestCommented:
did you try to do telnet to port 25 from command prompt,
if yes and the connection is closed after that, maybe it is because POP3 is a feature that can be set to every mailbox,
0
 
michaelshavelCommented:
This doesn't have anything to do with POP3. This has to do with setting up a reverse DNS pointer record in Exchange 2010 and the response that is sent to other mail servers when they issue an HELO command.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.