• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 512
  • Last Modified:

Cannot get CPU Frequency Scaling to work.

Many months ago, i removed powernowd from the mythbuntu installation as I didnt think it was needed.

Now, which the start of some hot weather, I'm thinking that running CPU Frequency Scaling will help to reduce the amount of heat this machine produces, which is A LOT!

So, I've done sudo apt-get install powernowd, but when i run sudo /etc/init.d/powernowd start, i get no errors, but there is no powernowd in the process list.

So I then tried sudo apt-get install cpufreqd cpufrequtils xfce4-cpufreq-plugin.

When running sudo cpufreq-info i get

cpufrequtils 005: cpufreq-info (C) Dominik Brodowski 2004-2006
Report errors and bugs to cpufreq@vger.kernel.org, please.
analyzing CPU 0:
  no or unknown cpufreq driver is active on this CPU
analyzing CPU 1:
  no or unknown cpufreq driver is active on this CPU

My CPU is an Intel Core 2 Duo E4300 1.8GHz, running Mythbuntu 9.10 (Karmic)
0
davepusey
Asked:
davepusey
  • 2
1 Solution
 
arnoldCommented:
http://www.thinkwiki.org/wiki/How_to_configure_powernowd
Below is an example of how to set the min/max frequency from the above link:
echo 825000 >/sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq
echo 2200000 >/sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq
You need to repeat the same for CPU1.
0
 
davepuseyAuthor Commented:
It turns out that SpeedStep was disabled in the BIOS.

Works perfectly now.
0
 
davepuseyAuthor Commented:
Self solved
0

Featured Post

Prepare for your VMware VCP6-DCV exam.

Josh Coen and Jason Langer have prepared the latest edition of VCP study guide. Both authors have been working in the IT field for more than a decade, and both hold VMware certifications. This 163-page guide covers all 10 of the exam blueprint sections.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now