• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 724
  • Last Modified:

SBS 2003 R2 with Exchange letting ipad and Nokia E17 update mail with Exchange server

Hi, Good points as I do not have a lot of information here but have full access to the iPad, Nokia E17 phone and
the Exchange server set up.
What I know
1. User says settings on his devices have not changed.
2. Another user uses HTC smartphone to access their email and it works fine.
3. User is using both local corporate Access Point and also the iPad's/Nokia's own internet
connection.
My presumption is that this is not a device config issue as both devices do not update.

I was thinking about trying to replicate the error but is this wise as the other user has mail
updates working OK.
If I create my own Exchange account and try and access mail via a phone with Microsoft
Exchange set up I guessI will get access OK.
The iPad does not contain any log entries for fault finding and I cannot see any logs in the
phone.

User wants iPad fixing first. Phone is set up with external ip address, DNS is OK with
mail10.n.co.uk where n is the domian.
Phone also has username and password entries.
I have not reset the password yet but asked the user to enter his password. If I change
the password in AD I assume it covers the email too and changes that.
I assume there is no way for the Exchange password to be seperate from the AD account
and be changed.
I have pinged the FQDN for the Exchange server twice and it came back with an external IP
different each time.

I am a time server administrator but have no local knowledge of thsi set up as I just took it over.
Please be patient!

Many thanks

Phil






0
philswift_tecorum
Asked:
philswift_tecorum
1 Solution
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
What I would do to sanity check the technical installation, and rule out the devices is the following:-

1. Check users do not currently have their passwords in an expiry state, where they are requesting to change their passwords in the domain but have not done it yet. (this is know to cause Activesync issues, away from the domain).

2. Use Microsoft Exchange Remote Connectivity Analyser here

https://www.testexchangeconnectivity.com/Default.aspx

obtain the usernames and passwords of your users, and YOU, go to this website, using their credentials, check there are no errors when you use their accounts details with this website.

Also check a working account as well.

This will perform tests and confirm if Activesync is setup correctly, and also confirm if the device and /or user accounts is the issue.

Good Luck

(users can be a pain in the bum!)
0
 
zipp83Commented:
hy see this - https://discussions.apple.com/thread/2016406?threadID=2016406
worked for in iphone sync problem.
0
 
Statick001Commented:
periodically my HTC handset simply stops syncing mail with exchange. contacts and calendar still work. the solution is to delete and re-create the exchange account on the handset (takes a few minutes of inputting the settings, then a few more minutes for the re-sync to happen), this resolves it until it somehow breaks again a few months later!
0
Veeam and MySQL: How to Perform Backup & Recovery

MySQL and the MariaDB variant are among the most used databases in Linux environments, and many critical applications support their data on them. Watch this recorded webinar to find out how Veeam Backup & Replication allows you to get consistent backups of MySQL databases.

 
philswift_tecorumAuthor Commented:
Thanks Static001, I need some root-cause analysis if possible, I can't have this as a solution as user would not accept it. Bit like having to reprogramme your car radio for all you stations every now and again. You'd take the radio or car back. Thanks anyway.
0
 
philswift_tecorumAuthor Commented:
Thanks Hanccocka, Ill work through what you suggested.
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Phil

We've been having issues, since every users now wants to use their own personal phone for Activesync, since it's been released to iPhone, iPad, HTC, once upon a time, it was only Windows Mobile Smartphones that had the technology, and we used to try and run a certified program of handsets for people, but they all wanted to use their own ipad, iphone or Nokia. It's a difficult call, and I don't know what your Organisation Policy is, if you have one, but in the end, most of the clients we worked with establshed a this is the recommended Organisation phone, if you choose to use your own, it's "not supported" or only on an "best endevaours" basis, and then the MD/CEO of most of the organisations, through a fit, because their HTCs stopped working!!!!

It's a difficult call, it was good in the old days, when we just had Windows CE PDAs, which although horrible devices, Activesync worked pretty well! (all the time, unless they needed rebooting every day due to Activesync memory leakage issues, and wouldn't sync!)
0
 
philswift_tecorumAuthor Commented:
Hi Hancocka

Yes the MD's iPad stopped working. I totally agree you need just one type of hardware for everyone, no exceptions. If users use their own devices they should be issued a verbal warning under the Acceptable Use Policy from HR and be asked to attend a small educational presentation on security and to explain why an company should Keep It Simple and needs to have only one type of hardware at a time. It is challenging enough to 'keep the plates spinning' without the plates being all different sizes and shapes.
It is a known issue and there is little root cause analysis as most forums say just delete the iPad mail entry for the Exhcnage server/mail account and rebuild it. That does not stop it from happening again.
1. I have changed the AD account password and logged his desktop off. Did not solve it
2. I have asked him to rebuild the iPad email account. I am waiting an update from the customer.
3. I am in the process of setting up OWA (Outllok Web Access) on the SBS2003 server as this was not working (service unavailable)
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
I thought it might have been the MD with a Ipad!

Did your tests with Exchange analyzer all come back 100% test okay?
0
 
philswift_tecorumAuthor Commented:
Hi Hancocka

SMTP in and Out is all OK. RPC over http fails on 4 counts. Will keep working through it.
0
 
philswift_tecorumAuthor Commented:
Seems it is the SSL certificate plus DNS issues. Deleted the current email for exchange entry in the ipad and recreated a new mail set up but did not choose mail for exchange but chose 'other' then manually set up mail account so it did not auto-detect. Used none SSL to bypass that while I get it sorted and also used the ip address instead of the mail server name.
0
 
philswift_tecorumAuthor Commented:
It was not a thorough answer
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
DNS should be easy to resolve, if you discuss with your ISP. Although will take 48/72 hours to replicate around the internet DNS servers.

We never use auto setup, because its always hit and miss.

As for SSL Obtain a certified one for uso with mobile devices.
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
i was waiting for you to get back with results to discuss further. The exchange remote analyzer is a quick guide, visual indication of what is incorrect.
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
in your original question, you stated dns was ok?
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now