We help IT Professionals succeed at work.

Check out our new AWS podcast with Certified Expert, Phil Phillips! Listen to "How to Execute a Seamless AWS Migration" on EE or on your favorite podcast platform. Listen Now

x

Windows 7 installation on brand new Asus motherboard based desktop, why it says no hard drive detected?

Medium Priority
464 Views
Last Modified: 2012-05-11
Hard drive was default as Raid. I changed it to ACHI and also SAT.  It still says no hard drive detected. However windows 7 installation sees the Hard drive and loads the files. Can any one help me to fix it.  I am in the middle of loading Windows 7,  I am not sure it is doing it right? thanks
Comment
Watch Question

Commented:
Wait, I don't get it. You say that 'something' doesn't see the hard drive, but Windows 7 installation does see the hard drive? Could you explain a bit more?

Author

Commented:
As soon as it starts up. Bios message comes. " Hard drive mode IDE. Hard drive not detected"
message comes. then reboots same message comes and it boots to windows7 then works fine no problem at all.  I installed all the drivers except video.  It works fine.  I just don't want the annoying message that says no hard drive found. thanks

Commented:
Okay. Are you able to enter your computer's BIOS? If so, you probably have setting for storage controllers there (the ones that allow you to switch between IDE, RAID and AHCI). Is any of them set on IDE? If so, set them all on AHCI or Auto.

If not, can you see anything else in the storage section that says IDE?

If neither of this helps, please post the exact model of your motherboard.
This is probably occurring because Windows 7 cannot see the disk controller because it does not have the proper drivers.  Download the latest disk controller drivers from the ASUS website for Windows 7.  Is this Windows 7 32 bit or 64 Bit?  Make sure to get the proper drivers for the proper installation.

During the installation you can choose the F6 key to install third party disk controller drivers from a separate drive media.  Or an easier solution would be to burn a new Windows 7 installation DVD and embed the controller drivers into the installation DVD.  You can find instructions on how to do this here:

http://www.wikihow.com/Slipstream-Your-Sata-Drivers-Into-a-Windows-Xp-Installation-Cd

Although this link is for Windows XP when you download the NLITE free utility make sure you find and download the Windows 7 version.

Top Expert 2009

Commented:
look for "hard drive pre delay" in the BIOS - enable it
and if possible, upgrade your BIOS firmware.

when you are switching on the computer from a cold state, the hard drive is taking more time to spin up and become operational.
listen closely to the sounds of startup - if you hear multiple scheech-zoom sound from the HDD then its time you either bought a new power supply, or replace the HDD.
Use this link for Windows 7 download

http://www.rt7lite.com/
Gary CaseRetired
CERTIFIED EXPERT
Most Valuable Expert 2013
Top Expert 2009

Commented:
It sounds like this message is from the BIOS -- NOT from Windows.    Not enough detail to say for sure ... but I suspect the message you're seeing is from the onboard RAID controller, which was originally set up to see the drive in RAID mode.

... enter the RAID controller (look in your motherboard documentation to see the key squence -- often Ctrl-A, but varies with different controllers) and disable the RAID BIOS.    That should eliminate the message.

Alternatively, the message could be because of an incorrect mode setting -- but be careful about changing the mode after you've installed Windows 7 ... if you want to switch to AHCI there's a registry key you have to change FIRST -- or it won't boot.


Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION

Author

Commented:
Switching the SATA cable connection on the motherboard fixed the problem.
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.