IIS not service default page after Windows 7 (Home Premium) SP1 upgrade

I performed a Windows 7 SP1 install yesterday as it was pushed to me as a Windows update. Since installing it the default page on a website I develop (index.php) no longer loads if I just point my browser to the site on my local machine. I've checked and Default page is enabled and index.php is at the top of the list and if I browse direction to index.php it all works just fine. I am authenticating as myself rather than the default user. This has been working just fine for over a year and only stopped working after the SP1 install. No other significant changes have been made to this machine.

I'd really like to get this working again. Whilst it's not the end of the work it is a real pain.
LVL 40
evilrixSenior Software Engineer (Avast)Asked:
Who is Participating?
 
evilrixSenior Software Engineer (Avast)Author Commented:
Ok, I finally managed to figure out how to make this work again! I added user "IIS_IUSRS" to the list of users who have access to that directory tree from the root the virtual site maps to.

What I don't understand is why has it always worked fine up until now and given that I am authenticating as a specific user (my user account, which has full admin rights) to I need to add IIS_IUSRS before it will work with the default page?

If someone can provide an explanation for that I'll split it my solution so as to assist others (and satisfy my curiosity).

Thanks.
0
 
evilrixSenior Software Engineer (Avast)Author Commented:
This is the error I am getting when attempting to browse to the root of the site:

Server Error in '/' Application.

Configuration Error

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately. 

Parser Error Message: An error occurred loading a configuration file: Failed to start monitoring changes to 'C:\development\site' because access is denied.

Source Error: 

[No relevant source lines]

Source File: C:\development\site\web.config    Line: 0 

Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.1

Open in new window


I also forgot to mention that when I click "Test Settings..." Authentication and Authorization both pass and the details state, "The specified user credentials are valid.".
0
 
Aaron TomoskySD-WAN SimplifiedCommented:
I've seen this same thing. After sp1 the iisuser user is roved from inetpub for no good reason. So all your sites no longer inherit permissions for this user from the root.
0
Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

 
evilrixSenior Software Engineer (Avast)Author Commented:
Hi aarontomosky,

>> After sp1 the iisuser user is roved from inetpub
Should inetpub actually grant access to the IIS user? My understanding is this is just the top-level folder for everything and isn't actually considered as part of any website. wwwroot does still havethe IIS user assigned. It was this fact that allowed me to figure out how to make things work again. I noticed that the default site (which is just the bog standard IIS place holder page) was still working. The only difference I could see was the IIS user so I added it and bingo it worked.

Whilst I have ostensibly resolved this problem it still doesn't make sense because I am not using the IIS user to access my development site. I am authenticating as myself(and as I said above the Test Settings confirm this authentication is successful. I have full access (at an ACL level) to all the sites file (I created them!).

Thanks for you thoughts but I don't think I'm any closer to understanding this mystery.
0
 
Aaron TomoskySD-WAN SimplifiedCommented:
I run a bunch of websites so I never use wwwroot. I put a folder in inetpub as the root of each site. When I did sp1 all my sites that weren't just HTML stopped working. Something with the asp/php engine not having permissions. Anyway, adding iisuser worked for me.
0
 
evilrixSenior Software Engineer (Avast)Author Commented:
I couldn't even access other dev sites that were just html index pages. I would like to understand why SP1 broke this.
0
 
Aaron TomoskySD-WAN SimplifiedCommented:
Maybe someone else knows why that broke. For me .HTML worked. It was just .asp and .php that broke.
0
 
evilrixSenior Software Engineer (Avast)Author Commented:
Thanks.
0
 
Jackie ManCommented:
My wild gues is that there is security problem with .NET Framwork 4.0 after Windows 7 SP1 update.

Actually, MS release another update for .NET 4.0 after release of SP1.

http://support.microsoft.com/kb/2468871
0
 
evilrixSenior Software Engineer (Avast)Author Commented:
Thanks for your thoughts jackieman. It is a bit of a mystery isn't it :)

I'm gonna leave this open for a few more days and if no one has any further thoughts I'll split my solution with the expert comments.
0
 
evilrixSenior Software Engineer (Avast)Author Commented:
Well, I never got to the bottom of this. I've accepted my solution and assigned the two experts, who did try to assist, 75 points each as a a show of appreciation for their efforts.
0
 
Jackie ManCommented:
Thanks for the feedback.

Actually, I have gone through the long list of security and fix updates included in SP1 and most of those updates seem to be irrelevant to your problem.

MS should have received numerous negative feedbacks on Win 7 SP1 as many strange new problems will be encountered by users after update of SP1. After all, the security of win 7 has been tightened with SP1 which creates the new problems.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.