Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Unable to connect some home PCs after replacing router

Posted on 2011-04-24
5
Medium Priority
?
413 Views
Last Modified: 2012-05-11
I just replaced an old D-Link DI-624S router (two of the ports had died) with a DIR-825. I have several PCs and a few other devices in the home network. The router is connected to a cable modem through which I have a broadband internet connection.

With the new router, PCs connected by cable connect fine and have access to the internet. iPads connect to the wireless connection without difficulty and have internet access. An old Sony Vaio running Vista Business connects through the wireless link and has internet access and a new Acer desktop using a D-Link USB wireless device connects through the wireless link and has internet access.

I have two PCs that can see the wireless connection to the router, one is a Vista desktop using a USB wireless link the other is a new Windows 7 Toshiba laptop using its built in wireless connection. Both allow me to connect to the router but they display the connection as a Public Unidentified Network and only allow local access. Nothing I can do will allow them to be connected with internet access. I've tried changing the Public status to Private on the Vista machine but it reverts to Public more or less straight away.

All these machines were connected to the old router without difficulty and wireless access was trouble free. Any ideas what's going on. All I've changed is the router and the password. I had to choose a longer password for the new router than the old one used.  Even the network name is the same as before.

If all the PCs couldn't connect I'd find it easier to understand but some being able to and some not seems very odd.
0
Comment
Question by:sjgrey
  • 3
5 Comments
 
LVL 51

Assisted Solution

by:Jackie Man
Jackie Man earned 1000 total points
ID: 35455327
Run the command below in command prompt:-

ipconfig /all >results.txt

and post back the results.
0
 
LVL 1

Author Comment

by:sjgrey
ID: 35455703
Thanks - see attached Toshiba-laptop-results.txt
0
 
LVL 10

Assisted Solution

by:CSIPComputing
CSIPComputing earned 1000 total points
ID: 35457024
Your laptop (Emma-Laptop) is not getting an IPv4 address from the router or DHCP server.

You are getting an auto configuration address 169.x.x.x.

Do your other devices have STATIC IP addresses? i.e. Did you set the address manually?

Can you set the IPv4 address of Emma-Laptop manually, to an address that is valid on your network, and not already in use?  If you do, do you get internet access?

0
 
LVL 1

Accepted Solution

by:
sjgrey earned 0 total points
ID: 35457140
I tried this but wasn't sure how to fill in all the fields, especially the "Default gateway" and DNS server settings.  

In case there is anything to be learned from them, the router  and wireless settings are shown in the attached PDFs.  The wireless PSKs are set and working with other devices but don't show up in the printout.   DIR-825-settings.pdf DIR-825-wireless-settings.pdf

Thanks for your help
0
 
LVL 1

Author Closing Comment

by:sjgrey
ID: 35489790
SOLVED!

While preparing the material for the previous post, I ran the router's wireless setup wizard.  This generated a very long random PSK.  I replaced this automatically generated PSK on the router with the one I'd chosen when first setting it up, the one the other wireless devices have been using sucessfully with this router, and the two devices that couldn't connect suddenly came on line.

The PCs that were causing me problems are now connected.  The laptop, running Windows 7, gave me the choice of network type and I selected Home.  The desktop with a USB wireless link, running Vista, identiifed the network as Public but allowed me to change this to Private.

Both are working as they should.  I presume it was something obscure that gor reset when I switched the PSKs back and forth.

Thanks for the help.  Perhaps there is a clue in this that will help someone else.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Are you one of those front-line IT Service Desk staff fielding calls, replying to emails, all-the-while working to resolve end-user technological nightmares? I am! That's why I have put together this brief overview of tools and techniques I use in o…
What monsters are hiding in your child's room? In this article I will share with you a tech horror story that could happen to anyone, along with some tips on how you can prevent it from happening to you.
This Micro Tutorial will show you how to maximize your wireless card to its maximum capability. This will be demonstrated using Intel(R) Centrino(R) Wireless-N 2230 wireless card on Windows 8 operating system.
Michael from AdRem Software explains how to view the most utilized and worst performing nodes in your network, by accessing the Top Charts view in NetCrunch network monitor (https://www.adremsoft.com/). Top Charts is a view in which you can set seve…

804 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question