Can't make ProfFTP running on Ubunto 10.4

Hi,

I start to setup ProfFTP for my Server to make FTP available.
The demon is running fine and reports no error but I can't access via Port 21 as I get no response there.
I read it may be a reason because of IPTables but I also fellow a thread how to open the port.

Here's the output for ProfFTP (whhy tcp6 only?):
tcp6       0      0 [::]:ftp                [::]:*                  LISTEN
unix  2      [ ACC ]     STREAM     LISTENING     1871666  /var/run/proftpd/proftpd.sock
unix  2      [ ACC ]     STREAM     LISTENING     1871674  /var/run/proftpd/proftpd.sock

And this is for IPTables:
Chain INPUT (policy ACCEPT)
target     prot opt source               destination
ACCEPT     tcp  --  anywhere             anywhere            tcp dpt:ftp
ACCEPT     tcp  --  anywhere             mydomain.com tcp spts:1024:65535 dpt:ftp state NEW,ESTABLISHED
ACCEPT     tcp  --  anywhere             mydomain.com tcp spts:1024:65535 dpts:1024:65535 state RELATED,ESTABLISHED
ACCEPT     tcp  --  anywhere             mydomain.com tcp spts:1024:65535 dpt:ftp-data state ESTABLISHED

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination
ACCEPT     tcp  --  mydomain.com  anywhere            tcp spt:ftp dpts:1024:65535 state ESTABLISHED
ACCEPT     tcp  --  mydomain.com  anywhere            tcp spts:1024:65535 dpts:1024:65535 state ESTABLISHED
ACCEPT     tcp  --  mydomain.com  anywhere            tcp spt:ftp-data dpts:1024:65535 state RELATED,ESTABLISHED

Can somebody help me please make FTP working?

Thanks

Andre
andre72Asked:
Who is Participating?
 
savoneCommented:
You only have the ports open for FTP (port 20)

You also need port 21 open, the following command should get you there.


iptables -I INPUT -p tcp --dport 21 -j ACCEPT

0
 
andre72Author Commented:
Thnaks bit it didn't solve the problem:
Chain INPUT (policy ACCEPT)
target     prot opt source               destination
ACCEPT     tcp  --  anywhere             anywhere            tcp dpt:ftp
ACCEPT     tcp  --  anywhere             anywhere            tcp dpt:ftp
ACCEPT     tcp  --  anywhere             mydomain.com tcp spts:1024:65535 dpt:ftp state NEW,ESTABLISHED
ACCEPT     tcp  --  anywhere             mydomain.com tcp spts:1024:65535 dpts:1024:65535 state RELATED,ESTABLISHED
ACCEPT     tcp  --  anywhere             mydomain.com tcp spts:1024:65535 dpt:ftp-data state ESTABLISHED

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination
ACCEPT     tcp  --  mydomain.com  anywhere            tcp spt:ftp dpts:1024:65535 state ESTABLISHED
ACCEPT     tcp  --  mydomain.com  anywhere            tcp spts:1024:65535 dpts:1024:65535 state ESTABLISHED
ACCEPT     tcp  --  mydomain.com  anywhere            tcp spt:ftp-data dpts:1024:65535 state RELATED,ESTABLISHED
0
 
upanwarCommented:
From another box execute below given command and post the output.

telnet <Ip address of ftp box> 21

telnet <Ip address of ftp box> 20
0
On-Demand: Securing Your Wi-Fi for Summer Travel

Traveling this summer?Check out our on-demand webinar to learn about the importance of Wi-Fi security and 3 easy measures you can start taking immediately to protect your private data while using public Wi-Fi. Follow us today to learn more!

 
LinuxNinjaCommented:
You can ignore everything you read about IPTables. You aren't using it to block anything. The policies are all set to ACCEPT, so none of those rules matters. You can clear all of those rules:

# iptables -F

Let us know the result of using the telnet command to test the ProFTPd response from another computer.
Even though you're seeing tcp6 as the LISTEN port, it will respond to IPv4 traffic... this is normal.

Just for giggles, make sure you're not setting your /etc/hosts.deny to block anything for FTP. Not sure if your ProFTPd is even using the tcpwrappers, though.
0
 
Gabriel OrozcoSolution ArchitectCommented:
Somehow I tend to think you are trying to access your FTP from outside a ROUTER, and you forgot to open the port 21 on the router and forward it to your ubuntu box. (Been There, Done That)

You first need to assure proftpd is answering at the localhost level and then part from there:
issue
ftp localhost
0
 
andre72Author Commented:
I'm sorry I've given up as no solution works.
But I tried vsftpd and after 5 minutes I could use my FTP and as I need just really native function for FTP I decide to keep using this demon.
I hope you agree if I split poins to everybody who tried to help ...

Thanks for your support
0
 
andre72Author Commented:
Like I wrote just choose an other demon and anything is fine
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.