• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 614
  • Last Modified:

Unable to connect through active sync

I was unable to route mail at all and was even unable to ping my DC from my exchange box. I had to repair exchange and it looks as I have mail routing again successfully from both the inside and the outside. Ive tried with the actual name of the server and even the ip directly. The problem I have now though is I can't access exchange thru activesync.  It is supposed to use SSL and I am able to use SSL from the web. It will connect and verify my account but as soon as I access the mail from my phone it states

"Cannot Get Mail"
"The Connections to the server failed"

I've also tried the MS knowledge base "http://support.microsoft.com/?id=817379" I also ran ActiveSync Tester Results:

SSL Certificate:
      Receiving ................................ OK
      Ensuring not Self-Signed ................. OK
      Verifying certificate .................... OK
ActiveSync:
      Checking for application ................. OK
      Checking version ......................... OK (6.5.7638.1)
      Checking protocols ....................... OK (1.0,2.0,2.1,2.5)
User Permissions:
      Checking "company.com/test" ......... FAIL

Result:
      ActiveSync detected, but not correctly configured. [HTTP 500: Forms-based auth enabled?]

Forms based auth is enabled
Any help would be great!
0
cwest420
Asked:
cwest420
  • 4
  • 2
1 Solution
 
CSIPComputingCommented:
You don't say which version of exchange you are using, and on which server version,  but if it's 2003 on 2003, try accessing the IIS config on the server, find the MicrosoftActiveSync virtual folder in the default web site, and check there's no odd IP restrictions, and also that the relevant users have access to the virtual folder.

Had this problem, and solved it with the above.
0
 
cwest420Author Commented:
Yeah...sry..guess that would help. This is 2K3 on exch2K3. I've checked the folder and there are no ip restrictions. Also wanted to add that I can connect to owa by ssl with no issues. Thanks for your reply
0
 
CSIPComputingCommented:
OK, What about user restrictions?  By default, users don't get access to the activesync virtual directory in IIS.

Give them access using the IIS Admin tool, and then try it again.
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
cwest420Author Commented:
well its def a user restriction. I just re ran Active sync tester...
SSL Certificate:
      Receiving ................................ OK
      Ensuring not Self-Signed ................. OK
      Verifying certificate .................... OK
ActiveSync:
      Checking for application ................. OK
      Checking version ......................... OK (6.5.7638.1)
      Checking protocols ....................... OK (1.0,2.0,2.1,2.5)
User Permissions:
      Checking "company.com/test" ......... FAIL

Result:
      ActiveSync detected, but access denied. [HTTP 403: Disabled for this user]
As for the access.. can you be a little more specific? By IIS Admin tool do you mean IIS manager? Just been working on this so long i dont wanna screw this up.  
0
 
cwest420Author Commented:
Well some how my website identification ip address had been changed... I set the ip address to "all unassigned" and my active sync was able to communicate once again. All my devices are now functional!!
0
 
cwest420Author Commented:
I fixed it by method mentioned
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now