[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 582
  • Last Modified:

Newly Created Microsoft Word Documents Are Automatically Being Saved As Open Office.org Writer

I have been using Microsoft Word 2007 for over a year without a problem. Then during the last month I have noticed that on an increasing frequency, new documents created in Microsoft Word become saved as an Open Office format. This is in spite of even choosing to do a "save as" and picking Word 2007 or 2003.

After searching online for different solutions, I tried them, but was unsuccessful. During my exercise in futility, I wound up installing the upgraded Java jre-6u24-windows-i586-iftw.exe. One of the suggested solutions I found online suggested creating a new document within OpenOffice and saving it as a Microsoft word document.

I tried that and received the attached screenshot error message which prevented me from accomplishing the goal. The version of OpenOffice.org that I have is 3.2.1.

How do I prevent this from happening in the future and how do I convert OpenOffice documents into Word, and have it "stick?" Thank you very much
OpenOffice-Java-problem.png
version-of-Word.png
0
photoman11
Asked:
photoman11
  • 6
  • 4
  • 3
  • +1
3 Solutions
 
jonahzonaCommented:
Are you sure it is saving it as a Open Office file? It sounds like your .doc and your .docx extensions just got associated with Open Office.

To see the extension, go to the folder that has the documents in it.

Press tools. If you can't see that option, press alt and it should appear.

Click Filder Options.

Click the second tab and scroll down to where it says "hide extensions for known file types". Turn it off.

Now the extensions should be shown on your office documents. What is the extension that it is showing?
0
 
GrahamSkanCommented:
Interesting. My Word 2007 doesn't have that format.

Various Word, HTML, XML, RTF and Works formats are all that are in my Save As types.

Do you have an Add-in to do it? This list of troubleshooting steps for Word misoperating includes removing Add-ins:

http://support.microsoft.com/kb/921541

 
0
 
photoman11Author Commented:
I don't know if you figured this out already, but I had installed Open Office a few years ago, but I never had this kind of problem before. The screenshots are showing everything mentioned by jonahzona.

I'm also including one that shows a save as type of Open Document Text (*.ODT) and another screenshot of all my ad-ins (none of which seem to have anything to do with Open Office).

I looked at the support link above and am totally confused by it. Please explain what if anything I should be doing with it.

Thanks for your help. I need it!
save-as-option.png
folder-options.png
add-ins.png
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
jonahzonaCommented:
It seems like it is possible your default app has been altered.

On the .doc right click and select Open With

Select microsoft word by don't click ok yet.

Make sure that the check box is selected at the bottom that says Always use the selected program to open this file type.

This will make all doc files default to word and should also change the icon.

This should fix part of the problem.

I will keep thinking about the docx problem.

0
 
jonahzonaCommented:
On further reading of your screen shot (I was on my phone. Just moved to computer) the above should completely solve your problem.

Let me know!
0
 
jonahzonaCommented:
A full explanation is that your word files WERE saving as word files (.doc), however at some point Open Office was switched to be the default application for these files.

This can happen inadvertently sometimes because a pop-up window asks you if you want to do so, and you simply click yes without realizing what you are agreeing to.

Once you have changed the default application back to Word, I would encourage you to reinstate the Folder Option that hides known file extensions, so that you don't accidentally mess up some files.

Again, this is done by going to the folder in question, clicking Tools (if not showing press Alt to show), selecting Folder Options, selecting the View tab and then re-checking the option that says "Hide extensions of known file types".

 
0
 
GrahamSkanCommented:
There is also an option in within Word (Office Button>Word Options>Save) where you can change the default save format. Perhaps that is set to the Open Office format.
0
 
jcimarronCommented:
photoman11--Try Control Panel|Default Programs|"Associate a file type with a program".
You can see what program is associated with .doc and .docx and change as desired from there.
0
 
photoman11Author Commented:
Update to the situation:

Word had been selected as the default application for the doc and docx file extensions.

I honestly don't know which of your suggestions were the silver bullet, but the problem seems to have been solved. In spite of that, I did go to the folder tab and rechecked the option that says "Hide extensions of known file types" and so far (I have not rebooted) everything still seems to be functioning correctly.

Graham, I checked your suggestion above and it was correctly set to Microsoft Word. At this point, it seems that everything is working as it should be, so I'm going to close the question out ...

Except one thing has happened, which I don't know is part of this 4 part of something else because it has happened rarely in the past. Namely, when using Microsoft Outlook and opening e-mails, it why was done with the e-mail and I did not want to delete it, I simply hit the < escape> Key to close the e-mail. Now, clicking on that key has no impact at all.

I have no idea if it's related to this issue, a separate issue, coincidental, or my computer definitely is haunted.
0
 
jcimarronCommented:
photoman11--Glad to hear the good news.  If you rebooted several times (or opened Word several times) in the course of trying solutions, that might have done it.
rechecked the option that says "Hide extensions of known file types"
I would not have done that.  Now when you Save a document, you will not see what file type it is being saved as.  And when you go to open a document file, you will not know either.
When you Save As you should have a window telling you what the name and file type of the file is and where you are saving it to.
0
 
jonahzonaCommented:
My only issue with your last response is that if Word was the default app for .doc files, then your screenshot would have shown a Word icon.

But that definitely wasn't the case there. It seems like you may have simply solved the issue while going through the steps.

The Outlook problem sounds like a separate issue. I would recommend opening a new thread for that.

Glad its working for you now!
0
 
jcimarronCommented:
photoman11--You say that in the past "I simply hit the < escape> Key to close the e-mail. "
That is strange.  As you then say, using esc has no impact on an open Outlook email message.  That is what hitting esc when viewing an Outlook email on my PC does.
0
 
photoman11Author Commented:
Okay then ...

So are you saying that I SHOULD NOT CHECK the option that says "Hide extensions of known file types"?
0
 
jonahzonaCommented:
You can leave the extensions shown, but know that there is a distinct possibility that you will end up changing an extension when you try to rename a file.

This will render the document/file unusable until the extension is fixed.

I usually leave this option checked unless I need to do some debugging.

0
 
photoman11Author Commented:
Thanks.
0

Featured Post

New feature and membership benefit!

New feature! Upgrade and increase expert visibility of your issues with Priority Questions.

  • 6
  • 4
  • 3
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now