[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 264
  • Last Modified:

why RDP can not access Server

hi,
we have three workstations all running win 7 and a server running win 2003. It is a backup copy of our main server .  However, due to a problem with our main server, we now need to use this back up server.
There is a problem. of three workstations, only one can access the server locally . We access it by using RDP and typing in the ip address..  192.168.1.2    .  

all machines can ping the server
all machines can type the \\192.168.1.2   from the run command, and see the shares
the server
all machines are on the same workgroup as all the other local workstations
but only one workstation can access it to work on it , from with in our local lan.

other offices are having no problem accessing it from accross the internet.

and we have ample license.

Thereis some relationship between the workstation and the server which is precluding a RDP connection.
.
i am not even given the oppurtunity to log in , i am just told that windows can not connect.

any ideas?
0
intelogent
Asked:
intelogent
  • 5
  • 2
  • 2
  • +3
7 Solutions
 
David Johnson, CD, MVPOwnerCommented:
try specifying the port to use i.e. 192.168.1.2:3389 or whatever port it is using as set in the servers registry
0
 
intelogentAuthor Commented:
ok... i will check back tomorrow... what is the degault?
0
 
David Johnson, CD, MVPOwnerCommented:
default is 3389 but it might have been changed as it is the backup server to prevent confusion
setting is located and the value is in hex
HKEY_LOCAL_MACHINE'SYSTEM'CurrentControlSet'
Control'Terminal Server'WinStations'RDP-Tcp

Open in new window

0
NEW Veeam Agent for Microsoft Windows

Backup and recover physical and cloud-based servers and workstations, as well as endpoint devices that belong to remote users. Avoid downtime and data loss quickly and easily for Windows-based physical or public cloud-based workloads!

 
mzafpkCommented:
Check if you are getting any error message on the workstation where RDP is not connecting. Please post the error if there is any.
0
 
helldesk_pitCommented:
Check RDP rule in firewall. It might be set to allow traffic from only one IP address instead of a whole subnet.
0
 
jsheplerCommented:
You might also make sure that the network type is set the same on all of the workstations. (i.e.  All set to the work or home profile instead of public).
Also is the backup server Windows 2003 as well or Windows 2008? When you check the firewall, check to see what the scope of the firewall rule is.
0
 
navaidfarooquiCommented:
change the network type to work or home on those two workstations ... it should work
0
 
intelogentAuthor Commented:
where do i check the windows firewall  please be as descriptive as possible.
0
 
helldesk_pitCommented:
Actually win 2003 does not have firewall. Is there a firewall between you and that server? (like cisco or juniper firewall)
0
 
intelogentAuthor Commented:
there are many, tomorrow i am going to the server. and will place a hub with just the server and my laptop... this will take much out of the equation.
i will report back
0
 
navaidfarooquiCommented:
Actually Windows Server 2003 Sp1 does have the Windows Firewall with advanced security as stated here
http://technet.microsoft.com/en-us/network/bb545423

and here

http://technet.microsoft.com/en-us/library/cc778148%28WS.10%29.aspx

but i would wait for your response first since you said you have many firewalls in between. Otherwise for a quickfire, if your laptop is windows 7, i will recommend you select the network type to Work or Home rather than public and then try..
0
 
intelogentAuthor Commented:
the mystery was in the registry.  but by remove all values of terminal services... and then reinstalling the latest RDP.... every thing started working...
0
 
intelogentAuthor Commented:
sorry,

the issue here was that a net work printer and and my local server had the same static ip...

go figure
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 5
  • 2
  • 2
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now