Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 468
  • Last Modified:

USB stick copying problems

Hello,

I was recently trying to copy some folders onto a Sandisk 8GB cruzer stick, the machine i was using has XP and the sandisk stick was pre-formatted, seem to have had some problems with this stick before,

So im using explorer to do a 'send to' of a complete folder to the cruzer drive, initially you see the window showing copying files (these are all just .jpg picture files on the machines hard drive copied direct from a camera via its SD card), then halfway through i get a message 'P1050432 cannot copy specified resource no longer available' this is one of the .JPG files.

I then try to see whats on the USB drive, and its totally blank, i try looking in proerties and it shows me 0 bytes free 0 bytes used, which is pretty odd.

I try plugging the USB drive into a Vista machine, it recognises it but makes a suggestion about checking it for errors, etc which i select (with the fix them option), and then it appears to be able to show the folders that the XP machine doesnt see any of.  If i put the 8G cruzer stick back into the XP machine at this point i was seeing nothing on it.

So i tried using another USB stick (this one a 1GB) on the XP machine, copied the same folder over and also got an error message while i was doing it) and similar problem when looking at properties as it showed the 0used/0free situation.  Also tried this stick on the vista machine and after the prompt to repair it, the data appeared to be on there OK, however although alll of the thumbnails display fine, several of them when you open them to view/see fullsize show corruption.

If i check the same picture files on the original XP machine, they view fine at fullsize, so i can only conclude they got corrupted while copying over.

Did some more investigation, and it now seems the Cruzer 8G has contents of what it did a long time before erased everything on it and tried copying the problem folders onto it.

The 8G stick shows as FAT32 format, and the 1G one just as FAT.

Ive tried using the 'error checking' in properties/tools for all of these drives and nothing is reported.

Are there any other utilities i can use to test the USB drives or fully re-format them incase the problem is something screwed in the FAT filing system ?  Is the problem to do with the machine im copying from or the USB drives or both?
0
Benboben
Asked:
Benboben
  • 2
1 Solution
 
dbruntonCommented:
>>  Is the problem to do with the machine im copying from

I'm suspecting this is the problem.  You should be able to format them in the Vista machine.  If so, use the NTFS file system.  As long as you don't use Windows 9x systems or Macintosh computers NTFS will be OK.

Also run chkdsk on the Windows XP machine.  Might be bad sectors or such on that hard disk.
0
 
BenbobenAuthor Commented:
Many thanks, it does seem to be related to the XP machines hard drive, i ran chkdsk from the prompt, and it discovered some errors in the MFT vis bitmap attributes, also in the volume bitmap?.

It seems like when you run the /F switch it only fixes them on boot up, so i got to the point where chkdsk was reporting no errors, chkdsk'ing either of the USB drives doesnt show any errors.

Then i made the mistake of copying a large folder with a lot of sub folders of .JPGs to the 8G USB drive, and it reports an error along the lines of cant find file or 'specified resource no longer available' !

Then the same situ where the USB drive shows 0bytes used / 0bytes free, and when i re-run chkdsk it pops the same errors about the MFT (see attached result).

Where now?
scan-dsk0590.JPG
0
 
dbruntonCommented:
That hard disk may be faulty.

Test the hard disk with the manufacturer's util or try the UBCD http://www.ultimatebootcd.com/

Download links are the icons at the top of the page above Overview.  Browse the page and see what utils are there for you.  Check the memory and hard disk utils especially.

Make the CD and boot from it.  Run the memory tester first - memtest -  and let it do two to three passes through your memory.  Memory might be causing a problem so get that test done first.

Then test the hard disk with the correct manufacturer's util for your hard disk.  Do the long test.  That will most likely tell you if your disk is corrupt.  Your problems could possibly be a failing hard disk as well so it won't hurt to do that.
0

Featured Post

Free recovery tool for Microsoft Active Directory

Veeam Explorer for Microsoft Active Directory provides fast and reliable object-level recovery for Active Directory from a single-pass, agentless backup or storage snapshot — without the need to restore an entire virtual machine or use third-party tools.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now