?
Solved

Ahsay Mail level backup

Posted on 2011-04-25
9
Medium Priority
?
1,130 Views
Last Modified: 2012-05-11
I've got 2 clients using Ahsay backup. The S/W has what they call a Mail level backup which backups up individual users exchange mailboxes. On these clients which each have about 30-50 users its not getting all the users backups. The problems is when you go into it's setup, you select Mail level backup and it lists the users and you put a check box in the accounts you want to backup.

The problem is that not all users accounts show up in the list. The accounts that do backup fine but I need to back them all up and some just don't show up. They are all users in the same AD OU group with no differences beyond being different people. Can anyone think of a reason some accounts wouldn't show up in the list to be selected?
0
Comment
Question by:Axis52401
  • 5
  • 4
9 Comments
 
LVL 7

Expert Comment

by:d3ath5tar
ID: 35459854
Permissions on the mailboxes?
0
 
LVL 2

Author Comment

by:Axis52401
ID: 35459893
I've compared every permission to accounts that do show up and to those that don't and they match exactly. The backup service users the domain administrator account to run and domain administrators have full mail box access.
0
 
LVL 7

Expert Comment

by:d3ath5tar
ID: 35459908
Ah... you see they do... but they don't.....

Domain admins are a protected group and by default even if you assign it exchange won't let you have it.

See Microsofts documentation for creating a ExMerge user and run your backups with that instead.... it's the same idea as a user for backup exec accounts and the like.... surprised Domain Admin allowed you to do that... makes me wonder if there some weird ACL applied somewhere....

0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
LVL 2

Author Comment

by:Axis52401
ID: 35459928
So what can I do here?
0
 
LVL 7

Expert Comment

by:d3ath5tar
ID: 35459960
I'd try the backup with an account that has the mailbox rights but is not Domain Admin.

What version of Exchange and AhSay are you using?
0
 
LVL 2

Author Comment

by:Axis52401
ID: 35459994
I've tried that I created a user called backup, set the service to use that account, added it to one of the missing users AD Exchange mailbox rights and restarted the serrvice and his account still doesn't show in the list.

Exchange 2003, Ahsay 5.5.7.4
0
 
LVL 7

Expert Comment

by:d3ath5tar
ID: 35460055
Sounds an odd one.... but I have heard about an issue affecting Ex2010, but your version of the client, where it doesn't always get the exchange data if the exchange paths are defined in lower case.... the fix is a replacement dll from AhSay....
0
 
LVL 2

Author Comment

by:Axis52401
ID: 35460149
Do you know what dll that might be, I could try that on ours and see if it helps?
0
 
LVL 7

Accepted Solution

by:
d3ath5tar earned 2000 total points
ID: 35460170
Not offhand.... sorry... you'd need to log a call with them to get it.

0

Featured Post

Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

How to effectively resolve the number one email related issue received by helpdesks.
Mailbox Corruption is a nightmare every Exchange DBA wishes he never has. Recovering from it can be super-hectic if not entirely futile. And though techniques like the New-MailboxRepairRequest cmdlet have been designed to help with fixing minor corr…
This tutorial will walk an individual through setting the global and backup job media overwrite and protection periods in Backup Exec 2012. Log onto the Backup Exec Central Administration Server. Examine the services. If all or most of them are stop…
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…
Suggested Courses

831 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question