We help IT Professionals succeed at work.

Check out our new AWS podcast with Certified Expert, Phil Phillips! Listen to "How to Execute a Seamless AWS Migration" on EE or on your favorite podcast platform. Listen Now

x

Need to route point all outbound mail in Exchange to an external relay - send connector help

guitar_333
guitar_333 asked
on
Medium Priority
366 Views
Last Modified: 2012-05-11
Hello,

I need to point my single Exchange 2007 server to an external relay.
I have the IP address, but I am not exactly sure how to setup the send connector.

I added a send connector pointing to the DNS name to be routed to, using MX records option selected. This then left me with two send connectors, I disabled the original one and now when I send out a test mail, I get:

Last Error: A matching connector cannot be found to route the external recipient
Queue ID: LAV-EXCH\Unreachable
Recipients:  check-auth@verifier.port25.com

I know Im missing something here... :)

Thanks!
Comment
Watch Question

CERTIFIED EXPERT
Author of the Year 2010
Top Expert 2010
Commented:
Unlock this solution with a free trial preview.
(No credit card required)
Get Preview

Author

Commented:
I added the DNS name to be routed to for the smarthost. and used * as the address space.

No error now, but messages just sit in the queue as "Ready"
CERTIFIED EXPERT
Author of the Year 2010
Top Expert 2010

Commented:
can you telnet to the hostname on port 25 from the exchange server?

Author

Commented:
Yes and I could successfully send a message, while connected, from my domain.

CERTIFIED EXPERT
Author of the Year 2010
Top Expert 2010

Commented:
Check the source server is set in the last tab of the send connector?

Also restart the Microsoft Exchange Transport service.

Author

Commented:
Under send connectors, I now have two. Should the old one be disabled?

Existing:
ADDRESS SPACE: type/SMTP address space/* cost/1 - scoped send connector: unchecked
NETWORK: Use DNS/MX to route mail/checked

New:
ADDRESS SPACE: type/SMTP address space/* cost/1 - scoped send connector: unchecked
NETWORK: Smart Host: FQDN (tested with telnet) - Use external DNS lookup setting is unchecked

The source server is the same on existing/working as well as the new one. That part should be good

I will try again and restart the service, but my question at this point is do I leave the existing send connector and the new one enabled at the same time? I would guess not...

Thanks!

Author

Commented:
Its working now! Thank you. I had a typo in the FQDN!! Doh!!!!
CERTIFIED EXPERT
Author of the Year 2010
Top Expert 2010

Commented:
Excellent, glad it's working.

Author

Commented:
If I could give you a hug instead of points, then I would...
CERTIFIED EXPERT
Author of the Year 2010
Top Expert 2010

Commented:
:)

The thought is there!! :)
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a free trial preview!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.