When accessing exchange 2010 owa using external link I'm getting error 403-Forbidden: Access denied. why?

we are still running exchange 2003 and recently introduced an exchange 2010 with the plans to migrate to exchange 2010. so far I transferred only one mailbox to the new exchange and when accessing external link mail.mycompany.com/owa getting an error 403. I searched online articles but no improovement so far. please help. thank you
levmik2000Asked:
Who is Participating?
 
abhijitmdpConnect With a Mentor Commented:
As far as I am looking at the web page it is asking for a certificate, you should install a valid certificate in your exchange server and this error will be removed automatically.
0
 
askurat1Commented:
Are you using HTTPS instead of HTTP?
0
 
askurat1Commented:
You can also redirect to HTTPS.
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

 
levmik2000Author Commented:
https always
0
 
askurat1Commented:
So you are still getting this error using https?
0
 
askurat1Commented:
Could I get a screenshot of the error?
0
 
levmik2000Author Commented:
yes, the same error, I think it is related to IIS7 but i'm not sure
0
 
askurat1Commented:
Does it look like the below error?
Error
0
 
levmik2000Author Commented:
yes,  exactly
0
 
askurat1Commented:
Anyway you could give me the link?
0
 
levmik2000Author Commented:
I just foun out from another sysadmin in my company that because of the recent spam/virus he removed public DNS from pointing to our new exchange server
0
 
askurat1Commented:
What do you mean exactly?
Does http and https point to the correct server?
0
 
askurat1Commented:
ports 443 and 80 need to point to the correct server.
0
 
levmik2000Author Commented:
not anymore the HTTP or HTTPS of the new server are pointing to the SPAM filter box .... I have to redirect it and then see if it will work.
thanks for you time .
0
 
abhijitmdpCommented:
Dear levmik2000,

You will need to setup external url to your OWA, ActiveSync and other CAS features also you'll need to setup public DNS that will point to your firewall (If you are using any firewall otherwise it will point to your internal Exchange 2010 server) and then only you'll be able to open OWA externally.
To setup redirection from HTTP to HTTPs you can follow one of my article at my blog site:
http://blog.onlinehelpboard.com/2011/03/27/redirecting-owa-urls-in-exchange-2010/
0
 
levmik2000Author Commented:
I just opened my firewall's web page and forward an IP to my exchange 2010 box. now I can get to my exchange 2010 box from outside but I have another error. something wrong with OWA virtual directory.
here is the link: just type this IP in the address bar. 67.107.108.134 (there is no public  DNS for this IP yet)
How can I fix OWA virtual directory?
thank you
0
 
abhijitmdpCommented:
Have you configured your external DNS to point to your firewall and made rules at firewall to connect to your exchange server. ???????
0
 
abhijitmdpCommented:
One more thing if one of your problem has been resolved then please close this question and open a new question in referance with this.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.