[Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 803
  • Last Modified:

Unable to deploy a solution in SharePoint

I'm trying to deploy a solution (WSP) file in our farm.
It keeps erroring out and getting stuck.
When I deploy the solution either with the GUI or STSADM it comes back failed and shows up in STSADM -o enumdeployments

How can I find out what the error is?  I'm looking at the logs in the 12 hive and I can't see what is causing the error.

Thanks
Ron
0
Capt_Ron
Asked:
Capt_Ron
1 Solution
 
kukdaiCommented:
What sort of permission you have in your farm. How you created the WSP solution.
what actually happens when you try to deploy does anything comes in the screen. Check the event viewer in your server if there is anything at that moment. See the account used for running the SharePoint timer services in your server where you trying to deploy.
0
 
Capt_RonAuthor Commented:
I'm a farm admin.
The WSP is a commercial 3rd party solution that has worked in our test farm.

We've narrowed the issues down to a problem with the Windows Sharepoint Administration Service
It won't start.

We recently updated the servers with a new antivirus app (From McAfee to LanDesk AKA Kaspersky)

The service was stopped on all the servers that had the new AV on them.  The CA and the Search server have seemed to fix themselves, but one of my front end servers will not work.  When we try to start the service, we get a timeout almost immediately.

I believe that if I were to remove the WFE from the farm and try to deploy the solution it would work fine, but I can't justify that yet.  I'm hoping, like an eternal optimist, that the server will right itself tonight.

If you've heard of this kind of issue before, please let me know how to fix it.
Thanks
Ron
0
 
navdeepmadanCommented:
Please Share the ULS logs error message.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
sandipkhardeCommented:
can you restart you share Point farm environment once ?
Make sure that you are using all domain account as devices account?
also provide event viewer log details ....
0
 
Capt_RonAuthor Commented:
Here are the messages I receive.

Dialog Box:
Error 1067: The process terminated unexpectedly

Application Event Viewer:
Log Name:      Application
Source:        Application Error
Date:          4/26/2011 7:36:34 AM
Event ID:      1000
Task Category: (100)
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      MOSSWFE1.palmbeach.k12.fl.us
Description:
Faulting application WSSADMIN.EXE, version 12.0.6420.1000, time stamp 0x49829bde, faulting module WSSADMIN.EXE, version 12.0.6420.1000, time stamp 0x49829bde, exception code 0xc0000005, fault offset 0x000000000000396e, process id 0x%9, application start time 0x%10.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Application Error" />
    <EventID Qualifiers="0">1000</EventID>
    <Level>2</Level>
    <Task>100</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2011-04-26T11:36:34.000Z" />
    <EventRecordID>301330</EventRecordID>
    <Channel>Application</Channel>
    <Computer>MOSSWFE1.palmbeach.k12.fl.us</Computer>
    <Security />
  </System>
  <EventData>
    <Data>WSSADMIN.EXE</Data>
    <Data>12.0.6420.1000</Data>
    <Data>49829bde</Data>
    <Data>WSSADMIN.EXE</Data>
    <Data>12.0.6420.1000</Data>
    <Data>49829bde</Data>
    <Data>c0000005</Data>
    <Data>000000000000396e</Data>
  </EventData>
</Event>


System Event Viewer:

Log Name:      System
Source:        Service Control Manager
Date:          4/26/2011 7:36:34 AM
Event ID:      7034
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      MOSSWFE1.palmbeach.k12.fl.us
Description:
The Windows SharePoint Services Administration service terminated unexpectedly.  It has done this 25 time(s).
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Service Control Manager" Guid="{555908D1-A6D7-4695-8E1E-26931D2012F4}" EventSourceName="Service Control Manager" />
    <EventID Qualifiers="49152">7034</EventID>
    <Version>0</Version>
    <Level>2</Level>
    <Task>0</Task>
    <Opcode>0</Opcode>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2011-04-26T11:36:34.000Z" />
    <EventRecordID>25192</EventRecordID>
    <Correlation />
    <Execution ProcessID="0" ThreadID="0" />
    <Channel>System</Channel>
    <Computer>MOSSWFE1.palmbeach.k12.fl.us</Computer>
    <Security />
  </System>
  <EventData>
    <Data Name="param1">Windows SharePoint Services Administration</Data>
    <Data Name="param2">25</Data>
  </EventData>
</Event>
0
 
Capt_RonAuthor Commented:
Where are the ULS logs?
12 hive or inetpub?

Also, I've tried the farm service account and local system account.
Thanks
Ron
0
 
kukdaiCommented:
ULS logs are in 12 hives just go to 12 hives there is a folder named LOGS you can easily find it
0
 
Capt_RonAuthor Commented:
Ended up working with Microsoft to rebuild config database.
They could not find a solution to fix the issue and recommended a farm rebuild.
0
 
Capt_RonAuthor Commented:
Opened ticket with Microsoft to resolve.
0

Featured Post

NEW Veeam Backup for Microsoft Office 365 1.5

With Office 365, it’s your data and your responsibility to protect it. NEW Veeam Backup for Microsoft Office 365 eliminates the risk of losing access to your Office 365 data.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now