We help IT Professionals succeed at work.

Check out our new AWS podcast with Certified Expert, Phil Phillips! Listen to "How to Execute a Seamless AWS Migration" on EE or on your favorite podcast platform. Listen Now

x

MailTips Could not be retrieved

netshops
netshops asked
on
Medium Priority
15,381 Views
Last Modified: 2012-05-11
I am having trouble with mailtips not showing up for users that are connecting from outside of the organization via Outlook Anywhere. I get the dreaded MailTips could not be retrieved. I did quite a bit of looking around and confirmed the following:

-MailTips work in OWA
-The ExternalURL is properly defined for EWS
-Autodiscover passes on testexchangeconnectivity.com

Upon further reading, it appears that it maybe something related to autodiscover but I am not sure what. Additionally, Free/Busy information does not seem to be working either.

My setup is as follows:

 Exchange Setup

-The firewalls that are depicted are Forefront TMG boxes.
-The site on the left is our Main site and the site on the right is our DR site.
-The CAS server are NOT in an array as they are in different AD Sites


Let me know if you need any other information.
Comment
Watch Question

Commented:
Can you set an out of office internally?
Can you set an out of office externally via Outlook Anywhere?

Author

Commented:
I am able to set one when connected internally and also via OWA. I am not able to set one externally via outlook anywhere.

I get the error:
Your automatic reply settings cannot be displayed because the server is currently unavailable. Try again later.

Commented:
From external do an outlook autoconfig test and look at the EWS URLs returned:
With outlook open, hold down CTRL key and right click on the Outlook icon in the bottom right hand side of your screen, then on the popup menu select the "Test Autoconfiguration". Select that, enter valid credentials and select the "autodiscover" option only and test.

Try and open the EWS URL in IE from explorer and see what you get.

Author

Commented:
I pulled up the tool (never knew that was there :) ) and under the protocol for Exchange HTTP, I typed the EWS URL into IE and got:


Error Code: 403 Forbidden. The server denied the specified Uniform Resource Locator (URL). Contact the server administrator. (12202)

Author

Commented:
I think that I may have found the issue...

Just for kicks, I decided to put autodiscover.domain.com instead of mail.domain.com in the ews URL and it prompted me for credentials. Once i authenticated, it returned a XML page. Do i just need to update the EWS URL in the autoconfiguration?

Commented:
Is your EWS URL something like
Https://mail.domain.com/EWS/exchange.asmx ?

Check that you are allowing anonymous auth on the EWS VD in IIS as per:
http://technet.microsoft.com/en-us/library/gg247612.aspx

Author

Commented:
I checked the security settings for EWS and they are as follows:

CertificateAuthentication     :
InternalAuthenticationMethods : {Basic, Ntlm, WindowsIntegrated, WSSecurity}
ExternalAuthenticationMethods : {Basic, Ntlm, WindowsIntegrated, WSSecurity}
LiveIdSpNegoAuthentication    : False
WSSecurityAuthentication      : True
LiveIdBasicAuthentication     : False
BasicAuthentication           : True
DigestAuthentication          : False
WindowsAuthentication         : True

Then curiosity got me and I started doing some log tracking on Forefront and it is the one blocking the connection. I started digging around in the configuration and remembered that we had to setup OA on the autodiscover URL becasue we have FBA on OWA and Basic Auth on OA and AS. Because we needed 2 different types of authentication (requiring 2 different listeners) we put OWA on the mail.domain.com and AS/OA on autodiscover.domain.com.

With that in mind, would an update tot he WebServicesVirtualDirectory External URL be in order followed by a restart of IIS?
Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION

Commented:
You can just recycle the AutoDiscover app pool in IIS instead of the whole of IIS to update the autodiscover URLs

Author

Commented:
First off...

THANK YOU for the help!

That was the fix. I really had never looked at the settings much but after seeing that little test in outlook, that is what tipped me off. After updating the URL and recycling the AutoDiscover app pool, everything is working now!

Thank you again for you help.

Commented:
No problem, glad it is working for you now.

Good work on checking Forefront too...
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.