[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1018
  • Last Modified:

cisco stack connections and ether-link catalyst 3750

Is there anyway to use the cables indicated in the attached drawing to form an 'etherchannel' between the two stacks. I want an alternative to using fiber in the gigabit ports for an etherchannel
stack-connections.JPG
0
adimit
Asked:
adimit
  • 12
  • 10
  • 2
  • +2
2 Solutions
 
EyeNoVoIPCommented:
No, the best you can do is create one stack from two.
0
 
FrabbleCommented:
In addition, stacking the switches means you don't have to do any link aggregation between them - the interconnects provide 16Gb both ways and allows the stack to appear as one logical unit increasing the functionality than you would get if they were separate.
0
 
EyeNoVoIPCommented:
True, but the 3750 has a 32-Gbps, high-speed stacking bus.  When configured properly the Bus can operate at Full Duplex.
0
Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
QuietFrankCommented:
I am not fully understanding what you are trying to accomplish. As noted earlier, there is no need for etherchannel when using Stackwise.

Do you have two stacks separated be distance that you are wanting to connect? The longest Stackwise cable is 3m. If it is longer you are out of luck with stackwise.

Depending on the model you have, you can go 10G between the stacks. If you dont have one that will do 10G now, you can purchase one for each stack. If you don't know if you can do 10G now, post your model number and I'll find out.

Frank
0
 
adimitAuthor Commented:
if using stackwise, how is the cabling done
0
 
adimitAuthor Commented:
What I want to do is to ensure that the two stacks act as one, as if I had an etherchannel connection between them. I can get the etherchannel to work. I want the same concept to work with hte cables indicated in the diagram
0
 
adimitAuthor Commented:
as seen in the diagram, I want the two separate stacks to act as one. I have assigned a standby IP address that represents the IP address of the both stacks.

I am not looking for an etherchannel between stacks
0
 
QuietFrankCommented:
How far away physically are the stacks?
0
 
adimitAuthor Commented:
next to each other
0
 
QuietFrankCommented:
If they are less than ten feet, you can connect one of the 10' stackwise cables and it will work.

They must have the same feature set. If you are not sure, do a show version and post here.

BACKUP BOTH CONFIGS. remove any trunks between the stacks.

Erase the config on the second stack.

Power down your second stack.

In the supplied pic, connect one 10' cable from the top left switch stackwise port 1 to bottom right port 2. get a second 10' cable and connect bottom left port 2 to top right port 1.

Power them up one at a time starting at the top. They should join the stack.

You can view which switch is which number stack member by pressing the button on the bottom left of the front of the switch. If you need to change the number, use this command: switch current-stack-member-number renumber new-stack-member-number  and then this one: reload slot current-stack-member-number .

Reference cisco doc:

http://www.cisco.com/en/US/products/hw/switches/ps5023/products_configuration_example09186a00807811ad.shtml#conf

GL

Frank
0
 
adimitAuthor Commented:
Here is a sample config from one of the switches. Both are identical. Tell me which statements need to be removed

interface Vlan13
 ip address 10.100.241.3 255.255.255.0
 standby 13 ip 10.100.241.2
 standby 13 preempt

SHOULD I REMOVE THE STANDBY ADDRESS?


interface GigabitEthernet3/0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-protocol lacp
 channel-group 1 mode active
!

SHOULD I REMOVE THE LAST TWO LINES IN THE ABOVE INTERFACE

interface Port-channel1
 switchport trunk encapsulation dot1q
 switchport mode trunk


SHLOULD I REMOVE PORT-CHANNEL1?

I Have an etherchannel configured. Are there any other lines to remove? The complete config is here:

errdisable recovery cause bpduguard
errdisable recovery interval 400
!
!
!
spanning-tree mode rapid-pvst
spanning-tree portfast bpduguard default
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
spanning-tree uplinkfast
spanning-tree backbonefast
!
vlan internal allocation policy ascending
!
!
!
!
interface Port-channel1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/1
 description Gérant 1 Filt.
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/2
 description Gérant 2 Filt.
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/3
 description Filtration 1 O
 switchport trunk encapsulation dot1q
 switchport mode trunk
 ip access-group 101 in
!
interface GigabitEthernet1/0/4
 description Filtration 1 E
 switchport trunk encapsulation dot1q
 switchport mode trunk
 ip access-group 101 in
!
interface GigabitEthernet1/0/5
 description Filtration 2 O
 switchport trunk encapsulation dot1q
 switchport mode trunk
 ip access-group 102 in
!
interface GigabitEthernet1/0/6
 description Filtration 2 E
 switchport trunk encapsulation dot1q
 switchport mode trunk
 ip access-group 102 in
!
interface GigabitEthernet1/0/7
 description Filtration 3 O
 switchport trunk encapsulation dot1q
 switchport mode trunk
 ip access-group 103 in
!
interface GigabitEthernet1/0/8
 description Filtration 3 E
 switchport trunk encapsulation dot1q
 switchport mode trunk
 ip access-group 103 in
!
interface GigabitEthernet1/0/9
 description Filtration 5 O
 switchport trunk encapsulation dot1q
 switchport mode trunk
 ip access-group 105 in
!
interface GigabitEthernet1/0/10
 description Filtration 6 O
 switchport trunk encapsulation dot1q
 switchport mode trunk
 ip access-group 106 in
!
interface GigabitEthernet1/0/11
 description Filtration 6 E
 switchport trunk encapsulation dot1q
 switchport mode trunk
 ip access-group 106 in
!
interface GigabitEthernet1/0/12
 description Filtration 7 O
 switchport trunk encapsulation dot1q
 switchport mode trunk
 ip access-group 107 in
!
interface GigabitEthernet2/0/1
 description Filtration 7 E
 switchport trunk encapsulation dot1q
 switchport mode trunk
 ip access-group 107 in
!
interface GigabitEthernet2/0/2
 description Coagulation
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet2/0/3
 description Gérant-Ozon
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet2/0/4
 description Eau Brute
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet2/0/5
 description Gérant-UV
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet2/0/6
 description Gérant-Chlo
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet2/0/7
 description Gérant Haut-P
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet2/0/8
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet2/0/9
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet2/0/10
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet2/0/11
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet2/0/12
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-protocol lacp
 channel-group 1 mode active
!
interface FastEthernet3/0/1
 description Filtration 5 E
 switchport trunk encapsulation dot1q
 switchport mode trunk
 ip access-group 105 in
!
interface FastEthernet3/0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet3/0/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet3/0/4
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet3/0/5
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet3/0/6
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet3/0/7
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet3/0/8
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet3/0/9
 description ATWF3
 switchport access vlan 100
 speed 100
 duplex full
 spanning-tree portfast
!
interface FastEthernet3/0/10
 description ATWF4
 switchport access vlan 100
 speed 100
 duplex full
 spanning-tree portfast
!
interface FastEthernet3/0/11
 description ATWF-OP1A
 switchport access vlan 100
 speed 100
 duplex full
 spanning-tree portfast
!
interface FastEthernet3/0/12
 description ATWF-OP1B
 switchport access vlan 100
 speed 100
 duplex full
 spanning-tree portfast
!
interface FastEthernet3/0/13
 description ATWF-OP4
 switchport access vlan 100
 speed 100
 duplex full
!
interface FastEthernet3/0/14
 description ATWF5
 switchport access vlan 100
 speed 100
 duplex full
 spanning-tree portfast
!
interface FastEthernet3/0/15
 description ATWF-OP5
 switchport access vlan 100
 speed 100
 duplex full
 spanning-tree portfast
!
interface FastEthernet3/0/16
 switchport access vlan 100
 speed 100
 duplex full
 spanning-tree portfast
!
interface FastEthernet3/0/17
 switchport access vlan 100
 speed 100
 duplex full
 spanning-tree portfast
!
interface FastEthernet3/0/18
 switchport access vlan 100
 speed 100
 duplex full
 spanning-tree portfast
!
interface FastEthernet3/0/19
 switchport access vlan 100
 speed 100
 duplex full
 spanning-tree portfast
!
interface FastEthernet3/0/20
 switchport access vlan 100
 speed 100
 duplex full
 spanning-tree portfast
!
interface FastEthernet3/0/21
 switchport access vlan 100
 speed 100
 duplex full
 spanning-tree portfast
!
interface FastEthernet3/0/22
 switchport access vlan 100
 speed 100
 duplex full
 spanning-tree portfast
!
interface FastEthernet3/0/23
 speed 100
 duplex full
 spanning-tree portfast
!
interface FastEthernet3/0/24
 description Pare-feu Cisco
!
interface GigabitEthernet3/0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-protocol lacp
 channel-group 1 mode active
!
interface GigabitEthernet3/0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Vlan1
 ip address 10.100.20.3 255.255.255.0
 standby 1 ip 10.100.20.2
 standby 1 preempt
!
interface Vlan13
 ip address 10.100.241.3 255.255.255.0
 standby 13 ip 10.100.241.2
 standby 13 preempt
!
interface Vlan23
 ip address 10.100.242.3 255.255.255.0
 standby 23 ip 10.100.242.2
 standby 23 preempt
!
interface Vlan33
 ip address 10.100.243.3 255.255.255.0
 standby 33 ip 10.100.243.2
 standby 33 preempt
!
interface Vlan53
 ip address 10.100.245.3 255.255.255.0
 standby 53 ip 10.100.244.2
 standby 53 preempt
!
interface Vlan63
 ip address 10.100.246.3 255.255.255.0
 standby 63 ip 10.100.246.2
 standby 63 preempt
!
interface Vlan73
 ip address 10.100.247.3 255.255.255.0
 standby 73 ip 10.100.247.2
 standby 73 preempt
!
interface Vlan100
 ip address 10.100.2.3 255.255.255.0
 standby 100 ip 10.100.2.2
 standby 100 preempt
!
interface Vlan101
 ip address 10.100.22.3 255.255.255.0
 standby 101 ip 10.100.22.2
 standby 101 preempt
!
interface Vlan102
 ip address 10.100.23.3 255.255.255.0
 standby 102 ip 10.100.23.2
 standby 102 preempt
!
interface Vlan103
 ip address 10.100.24.3 255.255.255.0
 standby 103 ip 10.100.24.2
 standby 103 preempt
!
interface Vlan104
 ip address 10.100.25.3 255.255.255.0
 standby 104 ip 10.100.25.2
 standby 104 preempt
!
interface Vlan105
 ip address 10.100.26.3 255.255.255.0
 standby 105 ip 10.100.26.2
 standby 105 preempt
!
interface Vlan106
 ip address 10.100.27.3 255.255.255.0
 standby 106 ip 10.100.27.2
 standby 106 preempt
!
interface Vlan107
 ip address 10.100.28.3 255.255.255.0
 standby 107 ip 10.100.28.2
 standby 107 preempt
!
interface Vlan108
 ip address 10.100.29.3 255.255.255.0
 standby 108 ip 10.100.29.2
 standby 108 preempt
!
ip classless


0
 
adimitAuthor Commented:
is the config from the first stack automatically copied to the second stack?
0
 
QuietFrankCommented:
Yes to the second post. It becomes like a 48 port module. The config for the first stack will not need to be changed much, mostly just the stuff going in between the 2 stacks. Let me look it over a bit and I'll post back.
0
 
QuietFrankCommented:
Also post a show version and show switch from each stack.

Frank
0
 
QuietFrankCommented:
#1 HSRP
Who is the standby router, the second stack? If so, remove it.
#2 G3/0/1
If this goes to the second stack, yes. Also remove the cable. Remove the second interface in Po 1 as well.  Looks like is G2/0/12.
Remove this out of the interfaces section on the copied config from stack 2 before you paste it into the merged stack.
#3 Po 1
I’m guessing that Po 1 goes to stack 2. Remove it.

FYI: Etherchannel and Port-Channel refer to the same thing.

Frank
0
 
adimitAuthor Commented:
unfortunately I don't have access to the switch right now.

If it becomes a 48-port stack how will I have redundancy. I have some client switches (IE3000). Each IE 3000 switch has one connection going to stack A and the other to Stack B. I presently have an ether channel configured.

If it acts like one big stack, will I still be able to have this 'star' like redundancy?
0
 
adimitAuthor Commented:
how do i clear the config on the second switch?
0
 
adimitAuthor Commented:
0
 
QuietFrankCommented:
You can clear the config by typing erase start and rebooting.

For redundancy, you'll have a port or more in each rack(same stack tho) for a port channel to the switch. Remember, when your done, it is "one switch." IIRC, if one of the ports drops the other ports operate normally.

So, the physical wiring for the IE3000 wont neccesarily change but the logical portion will.
0
 
adimitAuthor Commented:
Let me know when you've had a chance to go through the logical portion. That way I can see the changes. Keep in mind my second stack has the same config. Hence I'm assuming I will have gi4/0/x and gi5/0/x and fa6/0/x
0
 
adimitAuthor Commented:
as for redundancy, if I use this option then unplugging then wont unplugging the connection between the stacks make only the middle switches work?
0
 
QuietFrankCommented:
You are correct on the g4/0/1, g5/0/1.

I'm not understanding which redundancy you're referring to. switch redundancy or portchannel redundancy?

As far as connecting the IE3000, you would just create a new portchannel group and assign whichever interfaces you plug the IE3000 into.

Frank
0
 
adimitAuthor Commented:
Not to get too technical I want communication to my ie3000 even if one stack goes down or if I unplug one of the two cables on the IE3000. I'm assuming the port-channel handles this redundancy. If that;s the case then I assume I have to put the following command: channel-group 1 mode on  --- on each interface?
0
 
QuietFrankCommented:
There will only be one stack when your done.

You are correct. IRC, port-channel does handle redundancy in the way that you need. For more redundancy, add another link, in one of the other switches in the stack.

Frank
0
 
QuietFrankCommented:
adimit,

Just checking in, where you doing the switch over this weekend? Have any other questions?

Frank
0
 
QlemoC++ DeveloperCommented:
This question has been classified as abandoned and is closed as part of the Cleanup Program. See the recommendation for more details.
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 12
  • 10
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now