sbs 2008 gpo not being applied.

Posted on 2011-04-25
Last Modified: 2012-05-11
Hi All,
I have a client with a small network with 5 PC's (Vista Win 7 XP) and sbs 2008. No GPO are being applied. I have tried setting some logon scripts for Network Mapping and I know they work because if I browse to the folder the .vbs scripts are in from the client machine and run them from there they work fine. I have run rsop.msc and it shows me that the policys are being run  on the local machine but nothing is happening locally. I also have used the folder redirection wizard in the sbs console and that dosent seem to want to work either. I have run the GP modellingon the server and it says the GP should be applied. It is just not working and I am at my whits end. Any suggestions people please. Also I have truned off the firewall on the server and the local machine and still it doenst work
Question by:purpletriangle666

    Author Comment

    HI All,

    Just an update. It seems that the GPO's ARE being applied for XP but NOT for Vista, 2008 (on the server itself if I use gpupdate/force) or win 7
    LVL 21

    Expert Comment

    by:Larry Struckmeyer MVP
    The usual cause of this is that the stations and the server are not fully patched.  Client side extenstions need to be installed on the systems, as SBS 2008 was released before Windows 7.  Please use MS Updates on both the server and a recalcitrent station, then restart both.  Sometimes it takes a couple of reboots for the stations, or gpupdate /force, or both.  It can take some time.

    Author Comment

    Hi Thanks for that, but they are all fully up to date. I have however managed to get the logon scripts to run and stick if I logon with a domain user acount that hasnt had the account name and domain added to the local accounts. My usual way of setting up the primary user on a PC is to add them as a local admin to the machine and then log on through the domain. This seems fine with GPO and XP but not with Vista and Win 7. I am wondering if the local Policy for a user is running after the Group policy and screwing it up? Just a thought.

    Accepted Solution

    Just put the domain account back on the local PC and when restarted Policys not sticking. Deleted the domain account logged back in and lo and behold policys working!?!?!?

    Author Comment


    Author Closing Comment

    It was my solution

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    What Security Threats Are You Missing?

    Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

    I’m often asked about newer and larger USB drives connected to SBS2008 and 2011 failing Windows Server Backup vs the older USB drives not failing. As disk space continues to grow and drive technology change SBS2008 and some SBS2011 end up with the f…
    You may have discovered the 'Compatibility View Settings' workaround for making your SBS 2008 Remote Web Workplace 'connect to a computer' section stops 'working around' after a Windows 10 client upgrade.  That can be fixed so it 'works around' agai…
    This tutorial will walk an individual through the steps necessary to install and configure the Windows Server Backup Utility. Directly connect an external storage device such as a USB drive, or CD\DVD burner: If the device is a USB drive, ensure i…
    This tutorial will walk an individual through the steps necessary to join and promote the first Windows Server 2012 domain controller into an Active Directory environment running on Windows Server 2008. Determine the location of the FSMO roles by lo…

    779 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    14 Experts available now in Live!

    Get 1:1 Help Now