• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1405
  • Last Modified:

Unable to open Virtual Desktop from Citrix Webpart (XD5)

Hi Experts,

following Problem. My Customer is using a Citrix WebPart integration in Sharepoint 2007. Out of the WebPart i´m unable to launch the VirtualDesktops. The Desktop opens for about 5 seconds i can see the Windows login and then the Conneticon is closed unexpected.  All Other ways to Connect to the XD´s are working fine(Direct via WebInterface, Webinterface in Sharepoint, Connection via CAG).

Software Configuartion:
XenDesktop 5 with DDC-Version 5.0.0.145
Web Interface 5.4.0.59
Sharepoint 2007
Virtual Desktop with XP

Regards
Stefan Heber
0
sheber
Asked:
sheber
  • 4
  • 3
1 Solution
 
Jackie ManCommented:
Do you configure Authentication server as an Active directory?

Source: http://kb.juniper.net/InfoCenter/index?page=content&id=KB17987
0
 
sheberAuthor Commented:
Hi Jackieman,

sorry the Customer isn´t using Juniper. So´m not able to Check theses settings. The Way to connect is:
Cisco ASA --> Port 443 Forwarded auf ---> AGEE 9.2 ----> Netscaler 9.2 ----> WI 5.4

There are no Citrix or ICA Settings in the ASA.

Regards Stefan
0
 
Jackie ManCommented:
Check the setting on how the user authenicate to the Virtual Desktop in Cisco ASA.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
sheberAuthor Commented:
There are no Citrix or ICA Settings in the ASA.

0
 
Jackie ManCommented:
How about AGEE 9.2?
0
 
sheberAuthor Commented:

Hi All,

also nothing in the AGEE. But I’ve found the problem.

We disabled the Desktop Toolbar and everything worked fine. =>
Reason: SSO using XenDesktopToolbar only works with the newest ICA Client and ICACLIENT.ADM. You will need to enable the Checkbox "Allow pass-through authentication for all ICA connections"  inside the  "Local user name and password" Policy.

But be careful !!!!  You need to Upgrade ALL ICA Clients to 12.1.0.30 first and then upgrade your ICACLIENT.ADM Upgrading only the ICACLIENT.ADM will cause an Error launching Applications!

Alternatives:

Try to add "Desktop://DesktopGroupName" to the IE trusted Sites. If you have an blank in the DesktopGroupName you must use "-20" for the blank. I.e. Desktop://Windows-207 for a DesktopGroup named Windows 7.

Or Upgrade the ICA Client to 12.1.0.30 and set the following Registry Key:  XD5-Enable-SSO-ICA-12-1-0-30.reg

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Citrix\ICA Client\Engine\Lockdown Profiles\All Regions\Lockdown\Logon\Local Credentials]
"LegacyLocalUserNameAndPassword"="true"

Best Regards

Stefan

0
 
sheberAuthor Commented:
Solution was not usefull at all. He tryed to fix the problem in the total wrong way
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now