• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 674
  • Last Modified:

IIS configuration for application in default website

I had an IIS application (asp.net v 4) that was running fine. Then I wanted to run it under the default website (so I could use a UCC ssl). I created a virtual directory under the default website, and then converted it to an application. But when I run it, I get the error "Failed to map the path '/sitename'.

Some initial research suggests it was because of the '/ that precedes the name, however, I can't remove it.

Can someone direct to solve this problem?
0
JeReLo
Asked:
JeReLo
  • 4
  • 2
  • 2
2 Solutions
 
GkCommented:
Make sure the IUSR and Network service has permissions to the location where your virtual dir is located.
0
 
GkCommented:
The path also takes back slash?  \Abc instead of /Abc.
0
 
JeReLoAuthor Commented:
Ok, that's done, but problem remains. I noticed that the locations also give access to the defaultapppool, but this application uses a custom application pool (let's call it myapppool). I thought that myapppool should also have access to the directory, but didn't see how to add that as an entity when I was setting directory permissions. Do you think this is needed too?
0
Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

 
John ClaesSenior .Net Consultant & Technical AnalistCommented:
The identity that is used for the app pool is the user that must have rights to your directory.
The NetworkService is the default Identity but you can change this

right CLick the AppPool => choose Advanced Settings
See ProcessModel / Identity


but when Mapping is given as reason please check the folowing :

Rihjt Click your App in IIS.
Choose Manage Application => Advanced Settings
check if the Physical Path exists and see for the Rights (App pool user)
Check if you're using the Virtual path corectly

regards
0
 
JeReLoAuthor Commented:
How do I select the application pool identity, in order to set the permission on the folder? The application pool identity is set up in IIS, but it doesn't correspond with a user, and I need to select this user (or identity) to allow it a permission on the folder.

I found Advanced Settings, but there is no process model listed. The physical path is correct. The physical path credentials, is currently listed as Application user. My option is to set it as a specific user, but I prefer not to use that, as users will change passwords and cause application to fail. I prefer to use Application user (pass-through authentication) - but how?

Virtual path is listed as "/mysitename" in the Advanced setting page, but it is just "mysitename" under the default web site sub applications. I can't change that anyway.


0
 
JeReLoAuthor Commented:
poor beggar, you were right!
It was hard somehow, to integrate your answer.
I worked on another question and got to the answer you gave here.
0
 
John ClaesSenior .Net Consultant & Technical AnalistCommented:
I'm glad that it worked for you ;-)
I've looked at the other question and they indeed clarified my comment.

regards
ppor beggar
0
 
JeReLoAuthor Commented:
my comment leads to a clarification of steps
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: CompTIA Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

  • 4
  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now