We help IT Professionals succeed at work.

Check out our new AWS podcast with Certified Expert, Phil Phillips! Listen to "How to Execute a Seamless AWS Migration" on EE or on your favorite podcast platform. Listen Now

x

Remote connection over Oracle over wireless adapter?

cbeech1980
cbeech1980 asked
on
Medium Priority
1,453 Views
Last Modified: 2013-11-11
Hi all,

I'm playing with WAS 7 and clustering and have installed Oracle 11GR2 on my laptop that normally serves as a media PC in my lounge.

Everything is installed and working although I can't seem to connect to Oracle from my other machines. I have disabled all firewalls and still no joy.

I can SQL+ to it locally but when I try and access with SQLDeveloper I get "IO Exception : The network adapter could not establish the connection".

My Oracle PC is connected to the network via its wireless connection and I have updated the listener.ora file to include this line.....

LISTENER =
  (DESCRIPTION_LIST =
    (DESCRIPTION =
      (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC1521))
    )
    (DESCRIPTION =
      (ADDRESS = (PROTOCOL = TCP)(HOST = 192.168.1.103)(PORT = 1521))
    )
  )

...the change here is localhost for the the IP address of the wireless adapter.

I'm running short of ideas here!

Thanks,

Chris
Comment
Watch Question

Top Expert 2012
Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION

Author

Commented:
Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\Users\CBeech>telnet 192.168.1.103 1521
Connecting To 192.168.1.103...Could not open connection to the host, on port 152
1: Connect failed
Top Expert 2012

Commented:
Really a network issue.  There's something else blocking it.  
CERTIFIED EXPERT
Most Valuable Expert 2012
Distinguished Expert 2019

Commented:
On the database server from a command prompt post the results of: lsnrctl status
Top Expert 2009
Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION
CERTIFIED EXPERT
Top Expert 2008

Commented:
Turn off the firewall on your computer.
Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.