Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1369
  • Last Modified:

Remote connection over Oracle over wireless adapter?

Hi all,

I'm playing with WAS 7 and clustering and have installed Oracle 11GR2 on my laptop that normally serves as a media PC in my lounge.

Everything is installed and working although I can't seem to connect to Oracle from my other machines. I have disabled all firewalls and still no joy.

I can SQL+ to it locally but when I try and access with SQLDeveloper I get "IO Exception : The network adapter could not establish the connection".

My Oracle PC is connected to the network via its wireless connection and I have updated the listener.ora file to include this line.....

LISTENER =
  (DESCRIPTION_LIST =
    (DESCRIPTION =
      (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC1521))
    )
    (DESCRIPTION =
      (ADDRESS = (PROTOCOL = TCP)(HOST = 192.168.1.103)(PORT = 1521))
    )
  )

...the change here is localhost for the the IP address of the wireless adapter.

I'm running short of ideas here!

Thanks,

Chris
0
cbeech1980
Asked:
cbeech1980
3 Solutions
 
johanntagleCommented:
It sounds like it's still a network issue, because you should either get a TNS no listener error if the listener was down, or a different Oracle-specific error if you are at least able to connect to the listener.

What do you get when you try the following in the command prompt?

telnet 192.168.1.103 1521
0
 
cbeech1980Author Commented:
Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\Users\CBeech>telnet 192.168.1.103 1521
Connecting To 192.168.1.103...Could not open connection to the host, on port 152
1: Connect failed
0
 
johanntagleCommented:
Really a network issue.  There's something else blocking it.  
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
slightwv (䄆 Netminder) Commented:
On the database server from a command prompt post the results of: lsnrctl status
0
 
mrjoltcolaCommented:
Most commonly, wireless routers are NAT firewalls, so if you are trying to connect from the non-wifi network, you are likely blocked by the "router". Find out more details on the configuration of your WIFI router.

1) What is the IP address / network number of your non-WIFI PC, is it the same network or different?
2) Try pinging the IP address.
3) Usually WIFI uses dynamic addressing, so if you reboot, your IP address will sometimes change. This doesn't mix with Oracle as a server, you need to assign a static IP address to the laptop.
4) See if there is a "DMZ" option on the router (all Linksys routers have this option). You can set the the DMZ host to point to one specific IP address on the WIFI network, and pass all traffic.
5) If a DMZ option is not available, setup some port forwarding rules. At minimum, port 1521 needs to be mapped from your laptop's IP address to the WIFI router. If your port forwarding is limited, as in low-end routers, then you may not be able to map the dynamic ports that the Oracle listener also wants, so you need to reconfigure the listener.ora with USE_SHARED_SOCKET = true to force all traffic to stay on port 1521.


Another option is to reconfigure your WIFI router as an access point instead. This basically makes it act like an ethernet switch, and disables the NAT firewall functionality.

0
 
schwertnerCommented:
Turn off the firewall on your computer.
0
 
POracleCommented:
Network issue...Nothing to do with Oracle database.

From client follow this:-
Ping server with IP and name
If success in this step got to next step ELSE correct this with help of network admin
tnsping service_name(Configured in client tnsnames.ora)
if success in this step and still not able to access database then let us know ELSE correct this problem.
0

Featured Post

How to Use the Help Bell

Need to boost the visibility of your question for solutions? Use the Experts Exchange Help Bell to confirm priority levels and contact subject-matter experts for question attention.  Check out this how-to article for more information.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now