exchange 2010 server 2008 r2 SP1 fatal error during install, could not boot into safe mode, solved but would like advice...

Posted on 2011-04-26
Last Modified: 2012-05-11
hi all,

our exchange server just tried to install SP1 for server 2008 and during reboot and install of the updates a fatal error ocurred

the error was C0000034 i tried to boot into safe mode and it halted at classpnp.sys unable to continue

i found this thread
i didnt do the first bit i did the second bit editing the xml file, the server rebooted and finsihed updates

in update history it now says SP1 has failed, which is fine, atleast our server is back up!

ive downloaded the readiness tool and am going to run it on th server before attempting to install SP1 again

could anyone offer any advice or steps to take before installing this service pack and for any future reference what else can i do to make sure it doesnt happen again

is the readiness tool enough?
what else should/can i do?

Question by:awilderbeast
    LVL 9

    Expert Comment

    LVL 1

    Author Comment

    i already have it up and fixed, now i darent update any of my servers, i read about a windows update readiness tool

    i found it and have installed it (it comes as s hotfix) but i see nowhere i can use it?

    you know anythign about it?

    LVL 16

    Accepted Solution

    You actually cannot "use" it. It will "run" for itself:

    LVL 1

    Author Comment

    so it auto checks that the updates are safe to run before isntalling?

    how can i make sure that the error i had wont happen again when i try reinstall sp1?


    Featured Post

    Are end users causing IT problems again?

    You’ve taken the time to design and update all your end user’s email signatures, only to find out they’re messing up the HTML, changing the font and ruining the imagery. What can you do to prevent this? Find out how you can save your signatures from end users today.

    Join & Write a Comment

    Learn more about how the humble email signature can be used as more than just an electronic business card. When used correctly, a signature can easily be tailored for different purposes by different departments within an organization.
    The Delta outage: 650 cancelled flights, more than 1200 delayed flights, thousands of frustrated customers, tens of millions of dollars in damages – plus untold reputational damage to one of the world’s most trusted airlines. All due to a catastroph…
    This tutorial will walk an individual through the steps necessary to configure their installation of BackupExec 2012 to use network shared disk space. Verify that the path to the shared storage is valid and that data can be written to that location:…
    how to add IIS SMTP to handle application/Scanner relays into office 365.

    745 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    18 Experts available now in Live!

    Get 1:1 Help Now