We help IT Professionals succeed at work.

Check out our new AWS podcast with Certified Expert, Phil Phillips! Listen to "How to Execute a Seamless AWS Migration" on EE or on your favorite podcast platform. Listen Now

x

Exchange 2010 RPC over HTTP not working

liquid101
liquid101 asked
on
Medium Priority
1,231 Views
Last Modified: 2012-05-11
We are trying to enable RPC over HTTP.  The feature is enabled on the server.  We have installed this on the CAS/HUB role servers (2 servers - HLB).  

Within IIS 7, the authentication shows disabled within 20 minutes of changing the setting to allow Basic Authentication.  If I change the setting, it goes back to 'disabled' and continues not to work.

Do I need to restart  IIS to get this going?  I thought that you could change the authentication without an IIS restart.
Comment
Watch Question

AmitIT Architect
CERTIFIED EXPERT
Distinguished Expert 2017

Commented:
It is good to restart IIS after any changes.  Test it after restart IIS. Use below command

iisreset /noforce

Author

Commented:
Trying it now... Maybe I didn't reset IIS fast enough on the first attempt.  Within 5 minutes, I refreshed and it was 'disabled' again.  

I'll give it another 30 minutes to see if the change holds.

Author

Commented:
Still nothing after IIS restart.  Basic Authentication under RPC keeps defaulting to 'Disabled'.

I tested using Outlook 2010 and checking the connection status.  I came back after it wasn't connecting via HTTPS... trying then connecting via TCP/IP.  I checked the servers and RPC was back to 'disabled'.

Are there any settings within Exchange 2010 that may be changing the authentication setting in RPC back to 'disabled'?
Shreedhar EtteTechnical Manager
CERTIFIED EXPERT
Top Expert 2010

Commented:
Execute this from the power shell:
Set-OutlookAnywhere -Name Server01 -ClientAuthenticationMethod Basic

where server01 has to be you exchange server name

Author

Commented:
Even after using the cmdlet above within EMS, the Basic Authentication is still disabled.... I even tried enabling it after the cmdlet.  I did an IIS reset to lock in the change and nothing... still.

I don't know what could be causing this.
Technical Manager
CERTIFIED EXPERT
Top Expert 2010
Commented:
Unlock this solution with a free trial preview.
(No credit card required)
Get Preview

Author

Commented:
Should the change be reflect within IIS manager?  If so, I'm not seeing it in the RPC application under Authentication.

Thanks

Author

Commented:
Disregard... the changes did show up in IIS.  I'm now waiting to see if they hold.

THANKS!

Author

Commented:
I'm having a hard time testing it since all of our machines are domain joined and onsite... they try HTTPS, but default over to TCP/IP after a few seconds....  I'm not sure if RPC over HTTP is working just yet, but the settings are staying within IIS.  This is a good start.
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a free trial preview!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.