Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 931
  • Last Modified:

Remote.mydomain.com not working and out of office not working.

Please can anyone kindly help, we have a SBS2008 server running perfectly.
External access to Outlook Web access  works, Outlook anywhere works however we have two faults which I think mat be connected.
1. if why type https://remote.mydomain.com/owa externall y it works, if we type it internally it does not work, we have to type the internal ip address e.g. https://192.168.0.2/owa and that works.
2. If we try and use "out of Office" from within Outlook we get this error "Your automatice reply settings cannot be displayed because your server is currently unavailable"  If we access "out of Office" from Outlook Web Access it works.

Could both faults be caused by the facty that an internal ping of "remote.mydomain.com" does not give a result?

Thanks
0
samcory
Asked:
samcory
  • 3
  • 3
2 Solutions
 
OctInvCommented:
Sounds like a DNS issue to me.

What I would do, is assuming that your SBS server has only 1 network card connected to the same network as the clients and the router, go to your servers TCP/IP settings in the network card properties and ensure that it is pointing to itself for the DNS as well as making sure that you have the ISP DNS servers listed in the forwarders.
Once done, check the forward lookup zones in your DNS server for an a record of 'remote' under the zone 'mydomain.com' and make sure it points to your SBS server.
0
 
samcoryAuthor Commented:
The only ip in the network card dns is the ip of the server.

I am not sure how to put my isp dns servers into list of forwarders.

the forward lookup zone for my dns server does contain a  "remote"  that points to the ip of the server




 
 
0
 
OctInvCommented:
Type 'ipconfig /all' from the command line on the server to make sure that the DNS server is listed as itself.
If it is, then make sure that DNS forwarders are configured (use this article to find out how):

http://technet.microsoft.com/en-us/library/cc754941.aspx#BKMK_winui

If the forward lookup zone for 'mydomain.com' does contain an 'A' record for 'remote' pointing to the IP address of that server, then if you ping 'remote.mydomain.com' on the server it should reply back with it's own IP address.
If the server replies back from pinging 'remote.mydomain.com' and the clients don't, then maybe it's the clients that are pointing to the wrong place for DNS?  If the clients use the server for DHCP, then you will need to configure the DHCP options to assign the clients the IP address of the server as their DNS.  Once this is done, the clients should then get a correct reply back from a ping to 'remote.mydomain.com'.
Let me know how you get on.
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
samcoryAuthor Commented:
everything checks out,

If you ping remote.mydomain.com on the server you get the LAN address of the server.
if you ping on a workstation you get the WAN address of the server.

The workstations only have one DNS server given to them and that is of the SBS Server.

0
 
OctInvCommented:
So the workstations are getting a result then?
I'm now a little thrown though given that you typed earlier:
'an internal ping of "remote.mydomain.com" does not give a result'.

Either way, it surprises me that if both the clients and the server are pointing to the same DNS server (the SBS server) that they would give different results?

Flush the DNS on the clients (as well as checking the hosts file for static DNS entries) and then do an NSLOOKUP on both the server and on one of the clients to see if the results come out similar to the one below:  (For the purposes of this example, your server has the IP address of 192.168.100.1)

C:\Users\you>nslookup
Default Server:  server.mydomain.local
Address:  192.168.100.1

remote.mydomain.com
Server:  server.mydomain.local
Address:  192.168.100.1

Name:    remote.mydomain.com
Address:  192.168.100.1

>

Make sure that the 'A' record you checked earlier in the forward lookup zone of your DNS server has the LOCAL ip address of the server and NOT the external.
0
 
samcoryAuthor Commented:
not resolved
0

Featured Post

Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now