[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 876
  • Last Modified:

Cannot connect to a shared printer on a Windows XP SP3 machine

I recently replaced a user's computer. This user has a Xerox Phaser 7400dn printer directly connected to her Windows XP x86 SP3 machine. On her last machine, she had the printer shared and others could print to it. On this new machine, it is also shared but when people try to go through the Add a Printer Wizard, or by typing in \\computername\shared_printer_name, it comes up with the error message:
Windows cannot connect to the printer.  Either the printer name was typed incorrectly, or the specified printer has lost its connection to the server.  
I've tried adding the registry keys:
[HKEY_CLASSES_ROOT\CLSID\{77597368-7b15-11d0-a0c2-080036af3f03}] @="Web Printer Shell Extension"
[HKEY_CLASSES_ROOT\CLSID\{77597368-7b15-11d0-a0c2-080036af3f03}\InProcServer32] @="printui.dll" "ThreadingModel"="Apartment
which did not work either

If anyone has any insight into this problem, it would be greatly appreciated
0
ciphron
Asked:
ciphron
  • 3
  • 3
1 Solution
 
lvanalstyneCommented:
You are absolutely sure they are putting in the correct hostname and share name?
Make sure File and Print Sharing is enabled and there is a corresponding exception in Windows Firewall on the host computer.

Or just give it an IP address and have the users connect to it directly - it is a network printer after all.
0
 
ciphronAuthor Commented:
I am 100% sure. I type in \\computername\ and the printer name shows up as a drop down. I've also double checked on the user's computer and the name thats listed is the correct one that is shared.

The Phaser 7400 is a network-enabled printer, but since it doesn't have an ethernet cable plugged into it, its simply a local printer that is shared. And correct me if i'm wrong, but the fact that there is no ethernet cable leads me to believe that it will not be able to pull an IP from DHCP which in turn leads me to believe that its not technically a networked printer at this time.

The user's old computer had the exact same OS and exact same driver installed and it worked just fine from there. So i'm a little dumbfounded as to why it is not working now.

I could install a switch in the user's office and connect both the computer and printer to the network, but that will allow any and all users to access that printer as long as they have the IP address. We want the printer locked down to only allowing specific individuals to print to it. Thus the intent was to always share it, but only list it in the directory for short periods of time when installing the drivers on another system.
0
 
lvanalstyneCommented:
Keep in mind that the name of the printer that appears in the drop down is NOT the share name, although it should work when doing it this way through the add printer wizard. Sure they're not finding the old computer's name? Sorry to keep doubting - but I have often spent a lot of time trying to figure out why this is happening and it turns out I have one of those two things slightly wrong.

Try this:

Open up an explorer window on a second computer. In the address bar, type \\hostcomputername\C$.

If you connect, you should see the shared printer and clicking on it should connect to it. If you can't connect, either you have the name of the computer wrong or there is some other network issue, like the XP firewall is blocking access or Print and File Sharing is turned off.


OR Try this:

double check the new computer name and the printer share name (look at the printer's properties, and look at the Sharing tab).

On the second computer, go to Start > Run and type the following (case sensitive):

rundll32 printui.dll PrintUIEntry /in /n"\\hostcomputername\printersharename"

To add the printer globally on a computer for all users, replace /in with /ga


0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
lvanalstyneCommented:
Also you are correct that without a network connection, it cannot be used as a network printer. Also, if you want to go that route, you do not want to use DHCP as you will lose connectivity when it gets a different address. But if you want to lock it down you would still need to share it through a server or some sort.
0
 
ciphronAuthor Commented:
I forgot to mention that i already tried the \\hostcomputername\ and double clicked on the printer listed in there (which happens to be the same share name as is in the properties of the printer on the local machine - which is also what i tried when using the add a printer wizard), if i type \\hostcomputername\c$, that just brings me to their C drive - so there's nothing having to do with the printer there.

On my computer (not the host of the printer), I opened a command prompt and tried running rundll32 printui.dll PrintUIEntry /in /n"\\hostcomputername\printersharename" and it gave me the same error message as before, if i changed the /in to /ga, it simply goes down to the next line, but the printer never gets installed
0
 
ciphronAuthor Commented:
I'd like to object this question being deleted as abandoned because i found the solution.

We tried it using the ip address and it worked just fine. Turns out the issue resided in the computername of the host machine. it was 16 characters long. if we did \\computername-up-to-15-characters and double clicked on the shared printer, it also worked.
Thanks for the help
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now