Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

Help with cisco 877 - cannot connect to the internet

Posted on 2011-04-26
3
Medium Priority
?
491 Views
Last Modified: 2012-05-11
Hi,

I have just purchased a cisco 877 . my lan is working ok but I cannot get it to connect to the internet.

Can anyone check?
Current configuration : 5609 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname SCF-RTR01
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
logging buffered 51200 warnings
!
no aaa new-model
!
crypto pki trustpoint TP-self-signed-1411843790
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-1411843790
 revocation-check none
 rsakeypair TP-self-signed-1411843790
!
!
crypto pki certificate chain TP-self-signed-1411843790
 certificate self-signed 01
  30820241 308201AA A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 31343131 38343337 3930301E 170D3131 30343133 31313330
  34335A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 34313138
  34333739 3030819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  81009688 E1347197 593AF05B C789ED2C 558BD6AD 3DEB9EA4 43E1D2E8 690BED4B
  F8A4D4B3 AA1345A4 61B7E9C2 A19B025D 5295330E A6C96AEE 06E71DF8 818CF11B
  45AD58D1 1CDC71D6 2AC7DB66 06332179 A6BD3A06 1D35AD90 F209191A E6B8136F
  4C79EB88 79F2E669 445123D4 A78D9B08 3292046B 12B5D345 7DDA7458 CFDB9827
  A70B0203 010001A3 69306730 0F060355 1D130101 FF040530 030101FF 30140603
  551D1104 0D300B82 09534346 2D525452 3031301F 0603551D 23041830 16801431
  8D902DA3 41307E11 2BCB1B6A B3620871 7F8BE730 1D060355 1D0E0416 0414318D
  902DA341 307E112B CB1B6AB3 6208717F 8BE7300D 06092A86 4886F70D 01010405
  00038181 00486F14 324DFE19 3FDC12A7 22DF8545 95844697 45EB3891 1A9C42F7
  4B569E32 9D25D9C9 02B08DB8 E2937321 121C364F C6F36CC9 61DF610D 73AF22A4
  C2A96104 070800C4 B1BCB08B 6D69DCF7 A697A5E3 7C4CDA7D 54512E12 A0CD0A1C
  27148129 5F9BAED5 6A5BFCE1 F73F5F90 2246EAE1 F74C1775 22A5E03E 9C2AE38E
  7B5BD108 C9
        quit
dot11 syslog
ip source-route
ip dhcp excluded-address 10.10.10.1
ip dhcp excluded-address 10.14.1.1 10.14.1.49
ip dhcp excluded-address 10.14.1.101 10.14.1.254
!
ip dhcp pool ccp-pool
   import all
   network 10.10.10.0 255.255.255.248
   default-router 10.10.10.1
   lease 0 2
!
ip dhcp pool ccp-pool1
   network 10.14.1.0 255.255.255.0
   dns-server 62.24.128.18 62.24.128.17
   default-router 10.14.1.1
!
!
ip cef
ip name-server 62.24.128.17
ip name-server 62.24.128.18
!
!
!
!
username username privilege 15 secret 5 $1$n7a.$hcEeX6Eucy48DbgMPORr00
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
!
interface ATM0.1 point-to-point
 description $ES_WAN$
 pvc 0/38
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
 description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$
 ip address 10.14.1.1 255.255.255.0
 ip tcp adjust-mss 1452
!
interface Dialer0
 ip address 92.24.4.47 255.255.255.128
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication chap pap callin
 ppp chap hostname 02392639638@ecocallnet.co.uk
 ppp chap password 0 W4E5Z7U6U3
 ppp pap sent-username 02392639638@ecocallnet.co.uk password 0 W4E5Z7U6U3
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
access-list 100 permit ip 10.14.0.0 0.0.255.255 any
dialer-list 1 protocol ip permit
no cdp run

Open in new window

0
Comment
Question by:Dan560
3 Comments
 
LVL 18

Expert Comment

by:jmeggers
ID: 35468542
Can you ping your ISP from the router?
0
 
LVL 2

Author Comment

by:Dan560
ID: 35468586
Hi.

No I can't
0
 
LVL 10

Accepted Solution

by:
koudry earned 2000 total points
ID: 35501496
Hello,

Since you have Dialer 0, you may get rid off of the atm sub-interface. I suggest the following config:

!-----------------------
!

Interface ATM0
description DSL WAN link
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
load-interval 30
no shut
 pvc 0/38
 encapsulation aal5mux ppp dialer
  dialer pool-member 1
  no shut
!
!
interface Dialer0
 ip address 92.24.4.47 255.255.255.128
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication chap pap callin
 ppp chap hostname 02392639638@ecocallnet.co.uk
 ppp chap password 0 W4E5Z7U6U3
 ppp pap sent-username 02392639638@ecocallnet.co.uk password 0 W4E5Z7U6U3
!
!-----------------
!

I have added the command "dsl operating-mode auto" and left the dialer 0 configuration as is. If this does not work, I will post a modification of dialer 0 to use Multilink PPP.

You may want to turn on the following debugging before you change the config and capture the debugging log:

debug ppp negotiation
debug ppp authentication
debug ppp error

Is it possible to see "show version" and "show diag"?  I just want to make sure that the on-board DSL card is working with the IOS on the box.

Thanks.
0

Featured Post

Receive 1:1 tech help

Solve your biggest tech problems alongside global tech experts with 1:1 help.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Occasionally, we encounter connectivity issues that appear to be isolated to cable internet service.  The issues we typically encountered were reset errors within Internet Explorer when accessing web sites or continually dropped or failing VPN conne…
How to fix a SonicWall Gateway Anti-Virus firewall blocking automatic updates to apps like Windows, Adobe, Symantec, etc.
this video summaries big data hadoop online training demo (http://onlineitguru.com/big-data-hadoop-online-training-placement.html) , and covers basics in big data hadoop .
When cloud platforms entered the scene, users and companies jumped on board to take advantage of the many benefits, like the ability to work and connect with company information from various locations. What many didn't foresee was the increased risk…
Suggested Courses
Course of the Month15 days, 2 hours left to enroll

577 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question